Enlightenment Keyboard Locale

Hi to everyone

First of all sorry about my English.

Previously I used FreeBSD 8.1 with Gnome desktop (hald_enable, login with gdm, everything working fine also Turkish keyboard). Now I'm trying to use Enlightenment on FreeBSD 8.2-RC3. But I have a problem about keyboard locale. I'm using Turkish keyboard layout. Below I send you some of my system configs.

rc.conf
Code:
keymap=”tr.iso9.q”
font8×16=”iso09-8×16”
hald_enable=”YES”
dbus_enable=”YES”

login.conf
Code:
turkce|Turk Kullanici Hesaplari:\
	:charset=UTF-8:\
	:lang=tr_TR.UTF-8:\
	:tc=default:

profile
Code:
LANG=tr_TR.UTF-8; export LANG
MM_CHARSET=UTF-8; export MM_CHARSET

csh.login
Code:
setenv LANG tr_TR.UTF-8
setenv MM_CHARSET UTF-8

.xinitrc
Code:
exec /usr/local/bin/ck-launch-session /usr/local/bin/enlightenment_start
setxkbmap -layout tr &    //with or without nothing change
LANG=tr_TR.UTF-8; export LANG //with or without nothing change

command

Code:
startx | xinit

Xorg.conf.log
Code:
Option "XkbLayout" "us"

It must be

Code:
Option "XkbLayout" "tr"

I use HAL so there is no xorg.conf file. Turkish keyboard running very well on terminal (both root and user). But when I start Enlightenment with the startx command, it uses US keyboard layout. How can I use a Turkish keyboard on Enlightenment?

Best regards

Hasan
 
kisscool-fr said:
Do you have something in /usr/local/etc/hal/fdi/policy/ dir ?

No.

One of my friend Goksin told me that I must do Turkish Locale setup before installing any application. Because when compile any programs; compiler look to the system localization settings and then compile the program. May be this is the problem. Before all of this localization setup, I installed xorg, enlightenment and fluxbox. Now i'm trying installation from scratch.

Best regards

Hasan
 
In your .xinitrc file:

Code:
exec /usr/local/bin/ck-launch-session /usr/local/bin/enlightenment_start
setxkbmap -layout tr &    //with or without nothing change

The setxkbmap line will never be reached by startx. Put it before starting enlightenment.

Same remark for $LANG, but since it is already set in login.conf, it should already be set correctly.
 
hainan said:

Copy the file /usr/local/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /usr/local/etc/hal/fdi/policy/ dir and modify it to change the default us layout
Code:
      <merge key="input.xkb.layout" type="string">us</merge>
to tr
Code:
      <merge key="input.xkb.layout" type="string">tr</merge>

to make it the default.

If you want to make other changes related to your keyboard (driver, layout, variant, etc ... ), you have to do it in this file when you have hal support activated in xorg and if you use it (which is your case).

You have to reboot to activate your changes.
 
Fred said:
In your .xinitrc file:

Code:
exec /usr/local/bin/ck-launch-session /usr/local/bin/enlightenment_start
setxkbmap -layout tr &    //with or without nothing change

The setxkbmap line will never be reached by startx. Put it before starting enlightenment.

Same remark for $LANG, but since it is already set in login.conf, it should already be set correctly.

Hi Fred

I did what you say and it worked. Then I only changed the Enlightenment Language settings to Turkish -> UTF8 to fix a few Turkish Letter (character) problem. Now I'm using my Turkish Keyboard. Thanks a lot.


Hi kisscool-fr

There is no 10-keymap.fdi file in /usr/local/share/hal/fdi/policy/10osvendor/. Is this a problem? I did something wrong? Is this situation fixable?

Best Regards

Hasan
 
Sorry, I certainly made a mistake, I'm not currently on a FreeBSD system so I took information from my head.

You can get the exact location of the file with
Code:
pkg_info -xL hal | grep -i keymap

When you have it, you can proceed with it.
 
kisscool-fr said:
Sorry, I certainly made a mistake, I'm not currently on a FreeBSD system so I took information from my head.

You can get the exact location of the file with
Code:
pkg_info -xL hal | grep -i keymap

When you have it, you can proceed with it.

Hi, I have the same, but the same problem! I do not have that file and making a
Code:
pkg_info -xL hal | grep -i keymap
doesn't return anything.

Do I have to install anything? Can you share with us that file so that we can copy and make a new file? Thanks! I will wait for your answer ;) I did not find all character-key of my language (Spanish).
 
Top