Enlightenment Enlightenment Hangs Or Fails at Start

So, I just tried to put a Desktop (Enlightenment) on my shiny new FreeBSD installation. However, despite enabling D-bus, I still have some problems.

If I try to run Enlightenment, the final error reads: "..Cannot create a compositor." (Same if I run the command from the GUI started by startx.)

If, however, I run xinit, enlightenment will start, it just hangs on "loading module: tasks" forever.

This is only my second time trying to use FreeBSD, so I'd appreciate any advice.

(I don't *really* understand the hierarchy of software that a Window Manager depends upon, and I can't find a summary of this information anywhere!)
If I try to run Enlightenment, the final error reads: "..Cannot create a compositor." (Same if I run the command from the GUI started by startx.)
The message hints at compositing being an issue. You generally get that if your X doesn't have a proper 2D/3D accelerated driver.

What video card do you have and what's being detected in /var/log/Xorg.0.log?

Oh, and the hierarchy is something like: OS -> X Windowing Sytem (Xorg) -> Window Manager.

The X Windowing System (provided by Xorg) adds tools, drivers and libraries to create a graphical environment. A Window Manager takes care of placing frames around applications so you can move, close, maximize, etc those windows. A Desktop Environment adds a lot more functionality on top of that, things like a file manager, icons etc.

It's obviously much more complex than that but I think that pretty much covers the basics.
I have an nvidia GTX-750, and I use pkg install nvidia-drivers.
In that log I see a few things that (limited though my context may be) raise suspicion:

However is does detect my graphics card:
[    51.335] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 (GM107-A) at PCI:1:0:0 (GPU-0)

I see something about "EDID contradicts itself" and "not automatically adding GPUs" though.
Please post the whole Xorg.0.log on something like pastebin and post a link to it here. I'm sure it's something basic that's overlooked.
Your monitor seems to be lying a lot ;) But that shouldn't be a problem. There's no indication anything is amiss, so the Xorg part should be fine.

What's in your ~/.xinitrc?
vim ~/.xinitrc reveals "new file." Using the find command find / -name ".xinitrc" is also empty. I do not believe any home directory has such a file.

Also enlightenment_start does not work.
If there's no user ~/.xinitrc a startx should start the 'default' Window Manager, which is TWM.
And that, sir SirDice, is in fact what I have been using to post here. It is in fact usable, (that's how I've been doing my homework!) but I can't get anything, er more "contemporary" working. KDE has massive display problems, enlightenment hangs as advertised.

I am actually developing a taste for TWM, if you can believe that. But on principle, it would be nice if I could get to the bottom of what I did wrong with the desktop! (Even TWM froze once or twice.)
Try this:
echo exec enlightenment_start > ~/.xinitrc

That should create a correct ~/.xinitrc. Then try startx.
Starting enlightenment with startx and .xinitrc had literally no effect over just enlightenment_start.
Also, when I try to start the Kate text editor, it looks like KDE, and gives this error code:

X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x0

About a million times.
I've noticed in your Xorg.0.log file the installed NVIDIA driver on your system is version 346.96
(NVIDIA GLX Module 346.96), whereas the latest x11/nvidia-driver is 367.44.
I suggest to upgrade the nvidia-driver first.

For enlightenment:
If not done yet you should also upgrade all other applications and you should use the port version of the applications you want to upgrade/install. The packages often lag behind the port version, for example the x11-wm/enlightenment package enlightenment version is at , whereas the x11-wm/enlightenment version is at 0.21.2,2.

To decrease build time you can combine packages and ports with a ports management tool like portmaster() (--packages and --packages-build options)

As a side note: If you want the latest enlightenment version and like to experiment, there is a script. It downloads and installs Enlightenment from GIT (I've tried it on a 9.x FreeBSD RELEASE, it built and ran, needed some adjustments, the error messages are telling what to do).
Last edited by a moderator: