emX: watchdog timeout -- resetting

ozanus

New Member


Messages: 8

Hello there,
I'm using FreeBSD 7.2.
Code:
uname -a
FreeBSD pfSense.coslat.com 7.2-RELEASE-p5 FreeBSD 7.2-RELEASE-p5 #0: Tue Dec 29 15:11:00 UTC 2009     root@nw-
ds.com:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.7  i386
I'm getting
Code:
em1: watchdog timeout -- resetting
error, and this interfaces not running ...

I searched google and other mail lists and forums but i could not find any solution yet.

I tried this following steps ;

1- Entered system of FreeBSD 7.2, and add
Code:
hint.apic.0.disabled="1"
from /boot/device.hints. then restart system.

2- Change driver : http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17509&ProdId=3023&lang=eng

I compiled and installed driver to my FreeBSD 8 on virtualbox.

Code:
bsd8# tar zxvf /root/em-6.9.21.tar.gz -C /usr/src/
bsd8# make && make install
install -o root -g wheel -m 555   if_em.ko /boot/kernel
kldxref /boot/kernel
And copied if_em.ko to my FreeBSD 7.2 in /boot/kernel directory. And run this command [cmd=]kldxref /boot/kernel[/cmd]

Restarted system, but this problem still continues.

Does anyone have a definitive solution to this problem?

Thaks for supports.
 
Last edited:
OP
OP
O

ozanus

New Member


Messages: 8

I solved my problem.

Download FreeBSD 7.x intel ethernet driver from, http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17509&ProdId=3023&lang=eng

And run this following commands my pure installed FreeBSD 7.X;
Code:
# tar zxvf em-6.9.21.tar.gz -C /usr/src/
# cd /usr/src/em-6.9.21/src/
# make && make install
# echo 'hint.apic.0.disabled="1"'  >> /boot/device.hints
# echo 'if_em_load="YES"' >> /boot/loader.conf
# reboot
i didn't get Watchdog massage and ethernet card is running well.

Bye.
Ozan UCAR
 
Last edited:
Top