Solved Elantech touchpad issues

nekoexmachina

Well-Known Member

Thanks: 31
Messages: 340

#1
My laptop has this device:

Code:
root@moon:~ # dmesg -a | grep Elantech -A 20
Elantech touchpad hardware v.4 firmware v.0x361f01
psm: SEND_AUX_DEV_STATUS return code:00fa
psm: status 00 15 0c
psm: SEND_AUX_DEV_STATUS return code:00fa
psm: status 00 34 00
psm: SET_SCALING11 return code:00fa
psm: SEND_AUX_DEV_STATUS return code:00fa
psm: status 7c bc 01
  Model information:
   MaxX:       3260
   MaxY:       1793
   DpmmX:      32
   DpmmY:      32
   TracesX:    20
   TracesY:    11
   SemiMT:     0
   Clickpad:   1
   Trackpoint: 0
   CRC:        0
   Pressure:   1
elantech: END init
psm0: found Elantech Touchpad
It gets detected by my system properly after updating to 11-STABLE (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=205690)


However, I can not configure it properly and I strongly suspect that error is on my side.

What I've tried:

1) Set /dev/psm0 as synaptics device in /etc/X11/xorg.conf:

Code:
Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "synaptics"
    Option       "Protocol" "psm"
    Option       "Device" "/dev/psm0"
    Option       "ZAxisMapping" "4 5 6 7"
EndSection
result:

Code:
[  1630.859] (II) Using input driver 'synaptics' for 'Mouse0'
[  1630.859] (**) Option "CorePointer"
[  1630.859] (**) Mouse0: always reports core events
[  1630.859] (**) Option "Protocol" "psm"
[  1630.859] (**) Option "Device" "/dev/psm0"
[  1630.875] (--) synaptics: Mouse0: invalid x-axis range.  defaulting to 1615 - 5685
[  1630.875] (--) synaptics: Mouse0: invalid y-axis range.  defaulting to 1729 - 4171
[  1630.875] (--) synaptics: Mouse0: invalid pressure range.  defaulting to 0 - 255
[  1630.875] (--) synaptics: Mouse0: invalid finger width range.  defaulting to 0 - 15
[  1630.875] (EE) synaptics: Mouse0: Mouse0 Found no Synaptics, found Mouse model 15 instead
[  1630.876] (--) synaptics: Mouse0: no supported touchpad found
[  1630.876] (EE) synaptics: Mouse0: Unable to query/initialize Synaptics hardware.
[  1630.912] (EE) PreInit returned 11 for "Mouse0"
[  1630.912] (II) UnloadModule: "synaptics"
So no good.

2) Using sysctl's in hw.psm.elantech with "mouse" driver in xorg.conf

Result: Scrolling (neither two_finger scroll neither vscroll) doesn't work.

Any help?
 
Top