EEE901 - Looking for xorg.conf

xteraco

New Member


Messages: 9

I'm working on getting FreeBSD 7 going on my Asus EEE 901. I found an xorg.conf for it floating around on the web and it didn't work. Every time I try to use the configure tool, no luck. Can someone give me a copy of their xorg.conf. It would make my life a lot easier!;)
 

kamikaze

Well-Known Member

Reaction score: 76
Messages: 365

If Xorg still fails you should show us the contents of your /var/log/Xorg.0.log file. So we can find out what your problem is.
 
OP
xteraco

xteraco

New Member


Messages: 9

After running through the config utility about 1000 times, I found settings that worked. Now all I need to do is fine tune them. Thanks!
 

Ole

Active Member

Reaction score: 78
Messages: 121

mainlink said:
Would you mind sharing your .conf? Thanks.

My xorg.conf on Asus EEE 901:
Code:
Section "ServerFlags"
        Option          "AllowEmptyInput"
EndSection                               


Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0     
        InputDevice    "Mouse0" "CorePointer"
#       InputDevice     "Synaptics_Touchpad"    "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"            
EndSection                                                   

Section "Files"
        RgbPath      "/usr/local/share/X11/rgb"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/" 
        FontPath     "/usr/local/lib/X11/fonts/OTF"  
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/" 
        FontPath "/usr/local/lib/X11/fonts/URW/"       
        FontPath "/usr/local/lib/X11/fonts/bitstream-vera/"
        FontPath "/usr/local/lib/X11/fonts/cyrillic/"      
        FontPath "/usr/local/lib/X11/fonts/mozilla/"       
        FontPath "/usr/local/lib/X11/fonts/urwfonts-ttf/"  
        FontPath "/usr/local/lib/X11/fonts/webfonts/"                                                                                                                                                      
EndSection                                                                                                                                                                                                 
                                                                                                                                                                                                           
Section "Module"                                                                                                                                                                                           
        Load  "extmod"                                                                                                                                                                                     
        Load  "record"                                                                                                                                                                                     
        Load  "dbe"                                                                                                                                                                                        
        Load  "glx"                                                                                                                                                                                        
        Load  "GLcore"                                                                                                                                                                                     
        Load  "xtrap"                                                                                                                                                                                      
        Load  "dri"                                                                                                                                                                                        
        Load  "freetype"                                                                                                                                                                                   
        Load  "type1"                                                                                                                                                                                      
#       Load  "synaptics"                                                                                                                                                                                  
EndSection                                                                                                                                                                                                 

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"      
EndSection                     

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse" 
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection                                  

Section "Monitor"
        #DisplaySize      410   260     # mm
        Identifier   "Monitor0"             
        VendorName   "PTS"                  
        ModelName    "76f"                  
 ### Comment all HorizSync and VertRefresh values to use DDC:
        HorizSync    30.0 - 80.0                             
        VertRefresh  60.0 - 75.0                             
        Option      "DPMS"                                   
EndSection                                                   

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"             
        ### [arg]: arg optional                                      
        #Option     "NoAccel"                   # [<bool>]           
        #Option     "SWcursor"                  # [<bool>]           
        #Option     "ColorKey"                  # <i>
        #Option     "CacheLines"                # <i>
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "DRI"                       # [<bool>]
        #Option     "NoDDC"                     # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "XvMCSurfaces"              # <i>
        #Option     "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "Mobile 945GME Express Integrated Graphics Controller"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

note:
"/usr/local/lib/X11/fonts/URW/"
"/usr/local/lib/X11/fonts/bitstream-vera/"
"/usr/local/lib/X11/fonts/cyrillic/"
"/usr/local/lib/X11/fonts/mozilla/"
"/usr/local/lib/X11/fonts/urwfonts-ttf/"
"/usr/local/lib/X11/fonts/webfonts/"

is not included in xorg contrib, so i installing it from x11-fonts apart from xorg
 
OP
xteraco

xteraco

New Member


Messages: 9

Thanks for posting that, I will try it in a minute. Here is the best one I was able to generate with the configure utility.

Code:
Section "Module"
    Load        "dbe"  	# Double buffer extension

    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

    Load        "freetype"
    Load       "glx"
EndSection

Section "Files"

    FontPath   "/usr/local/lib/X11/fonts/misc/"
    FontPath   "/usr/local/lib/X11/fonts/TTF/"
    FontPath   "/usr/local/lib/X11/fonts/OTF"
    FontPath   "/usr/local/lib/X11/fonts/Type1/"
    FontPath   "/usr/local/lib/X11/fonts/100dpi/"
    FontPath   "/usr/local/lib/X11/fonts/75dpi/"
    FontPath   "/usr/local/lib/X11/fonts/local/"

EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"kbd"

    Option "AutoRepeat" "500 30"
    Option "XkbRules"	"xorg"
    Option "XkbModel"	"pc101"
    Option "XkbLayout"	"us"
    Option "XkbVariant"	"keyboard"

EndSection

Section "InputDevice"

    Identifier	"Mouse1"
    Driver	"PS/2"
    Option "Protocol"    "Auto"	# Auto detect
    Option "Device"      "mouse"
    Option "ZAxisMapping"   "4 5 6 7"
    Option "Emulate3Buttons"

EndSection

Section "Monitor"

    Identifier  "monitor"
    HorizSync   31.5
    VertRefresh 50-70

EndSection

Section "Device"
    Identifier	"Standard VGA"
    VendorName	"Unknown"
    BoardName	"Unknown"
    Driver     "vga"

EndSection



Section "Device"
    Identifier  "vidkard"
    Driver      "vesa"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "vidkard"
    Monitor     "monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
	Modes "1024x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
	Modes "1024x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
	Modes "1024x600"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"


    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection
 
OP
xteraco

xteraco

New Member


Messages: 9

Sorry for double posting, I don't see how to edit my message. @Ole, I tried your config and it did not work. I changed it just a little and now it works.

I added DefaultDepth, and Modes "1024x600" in Screen. The config still did not work. In Device I changed "intel" to "vesa". Now it goes in to X, but the mouse will not work.

I suspect vesa is my only option because I don't have intel modules installed? Any ideas for the mouse?
 
OP
xteraco

xteraco

New Member


Messages: 9

Fixed. I changed protocol to SysMouse and device is /dev/sysmouse. To find this I went in to sysinstall and tinkered around. It was in the description of the mouse config page. If anyone wants to see my conf file let me know.
 

mathuin

Member


Messages: 45

xteraco, I'm interested in your xorg.conf, especially after you get the intel driver installed. :)
 
Top