Other Dwarf version mismatch: GCC6 libs vs GDB

Opu

New Member


Messages: 1

I'm running a Fortran program under GDB and GDB complains that the Dwarf version in several GCC6 libraries is 4 and should be 2. I had the same problem with my program and fixed (?) it by compiling with -gdwarf-2, but I can't do that with the GCC libraries. I'm wondering if I should somehow update GDB to be consistent with GCC6 and Dwarf version 4. The GDB version is 6.1.1.
 

tankist02

Well-Known Member

Reaction score: 47
Messages: 326

I was told by a FreeBSD developer that gdb in the base is quite old and almost useless. You need to install gdb from ports to get the latest version.
 
  • Thanks
Reactions: Opu
Top