Solved DVD detecting issue

Hi all, I am new to FreeBSD. I am got in a trouble that when I am trying to burn a DVD using brasero or k3b. They are not detecting the blank DVD or CD. Can anybody help?
 
Try using a command line utility like cdrecord. Getting brasero or other GUI-based CD burners takes a few extra steps on FreeBSD, if you google you should find the instructions somewhere, I've gotten it working before but I forget what I had to do, something about setting the permissions right.
 
But can anyone tell me what kind of problem it is. As desktop panel in KDE or gnome is showing the blank DVD but k3b or brasero is saying to insert blank DVD. Does it mean that the DVD burning tool is not detecting the DVD or something else??
 
Don't try to mount the blank cds, if you have. Try ejecting and reinserting the DVD or CD, because that sometimes shows. Does Grell 's advice about using cdrecord work? If that does, it's probably the permissions or other GUI related settings.

Did you add your user to the wheel and operator group in /etc/group? There was another way to do it for users who don't need privileges to these two groups.
 
It looks like the drive detects the medium, but K3b and brasero do
not detect the drive. Do they give any indication that they do ?
Did you try Xfburn ?

Do burn backends find the drive at all ?

cdrecord -scanbus
xorriso -devices


If it is the only DVD drive in the computer, the address is supposed
to be /dev/cd0. You may inquire what the drive recognizes as loaded
medium by

xorriso -outdev /dev/cd0 -toc

If it believes to be empty, the xorriso messages will contain the line

Code:
    Media current: is not recognizable

If there is a medium recognized, then its type will be reported

Code:
    Media current: DVD+RW

Another inquiry run would be

dvd+rw-mediainfo /dev/cd0

Watch for lines

Code:
    :-( no media mounted, exiting...

or
Code:
    Mounted Media:         1Ah, DVD+RW

If it is clear that the backends detect drive and medium, then obviously
the GUI frontends do not ask their burn backends but rather some device
managing software which is either not available or mislead. (I could tell
names on other OS. FreeBSD 8 is refreshingly free of such annoyance.)

This thread talks of "hal" and re-compiling backends (which would mean
that ioctl numbers differ between FreeBSD installations ?):
http://lists.freebsd.org/pipermail/freebsd-questions/2012-April/239993.html

If the backends work and you tell the actual DVD task you want to
perform, then iI could possibly propose a command line for the backend
of your choice.
 
Thanks SirDice. I have just gone through that page but nothing happened to me. I added lines to /etc/devfs.conf:
Code:
#link  cd0  cdrom
#link  cd0  dvd
perm  cd*  0666
perm  xpt*  0666
perm  pass*  0666
But the dvd driver is still undetectable. even Virtualbox is unable to detect CD or DVD from it.
 
i have uploaded my screenshot.
 

Attachments

  • snapshot2.png
    snapshot2.png
    389.1 KB · Views: 437
Don't know how but after a restart now k3b is detecting DVD and CD also Virtualbox is detecting bootable DVDs.Thanks to all FreeBSD forum members who have helped me or tried to help me.
 
don't know how but after a restart now k3b is detecting dvd and cd
Did you restart devfs(8) after making changes to /etc/devfs.conf? A reboot certainly will have restarted it, which is probably why it didn't work at first but after a reboot it did.
 
Back
Top