Dumbest computing mistake you've made?

Ripped this topic idea from the ArchLinux forums, but there are some pretty darn interesting stories on there.

What is the dumbest computing mistake you've made?
Rebooting the wrong box, rm -rf, running sql statement for all users to resetting password to null etc.
I remember my first encounter with visudo... :D

# %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users  localhost=/sbin/shutdown -h no 

-- help 


man help 



I ran rm -rf in the wrong directory. As a result, I deleted about 200,000 records from our production system that had no backup. Yeah, it kinda sucked.
A few years ago at work we were migrating a couple of AIX server disks from SAN attached to SAN volume controller ( basically a storage virtualisation layer ).

The first server came up with all its disks and volume groups ok. When I brought up the second server, the root volume group was ok, but I couldn't bring up the data volume group. So after hours of scratching my head and mucking around i finally decided to do a restore on the second server.

Little did i know while i was restoring to the second server i was simultaneously killing the first. It turned out our storage guy did a bad copy and paste while preparing his scripts and didn't double check the values. He accidently zoned some of the disks to both the first and second server. :(


Staff member
Blowing up my C64 by connecting to wrong pins on the expansion port trying to reset the thing, check. rm -rf'ing the wrong directory, yep, did that. Losing my geli keys, did that too. Executing the wrong SQL query, yep, been there, done that. After 25 years of computing of which 15 professionally, I think I made every mistake in the book :e

Worst mistake however was on my first job, a computer repair shop. Customer wanted us to build in his new harddrive. Already had a drive in there, partitioned as C: and D:, a primary and an extended partition. Added the drive, partitioned it and formatted E:.

But guess what happens when you add a new drive with a new primary partition? Yes, the drive letters move around (primary partitions are listed first). So I ended up nuking the customers data on E: which was the old D:. Norton disk doctor didn't help getting the stuff back too. My boss was cool about it though, the customer wasn't :(
I worked for a big health insurance company, that ran a VAX cluster. At the time I was in charge of processing transplant related claims, which was the high claims job there was. Once I got to the level the gave me access to VMS mail. To this point, no one new I was a "hacker". I discovered that with VMS mail came access to the system and began to explore. There was no X or anything. So I happen to stumble upon the netscape navigator binary...so of course, without thinking, I was going to try and access the internet from my no X dumb terminal. I tried to get it to run and ended up issuing a command line that crashed the VAX system running our claims shop...I got up a took a long smoke break. Came back and acted shocked. It was the only time in my 5 years there that anything like that happened, eventually my boss found out and we became good friends...which leads to my really bone head move...

A few years later my former boss called me to come work as a Analyst for a start up Behavoiral Health insurance command. After 3 months they told me they were getting ride of my position but putting me in IS because of my "geekiness". At the time IS consisted of 3 people and I made 4, so we all did everything. One day, no one was around and there was a problem with a customer service phones so I was going to long into the AT&T phone switch and see what was up. I ended up typing the root password incorrectly 3 times, which locked the system. No big deal I thought, call at&t support. The only problem was they need to send a technician to fix that problem and that would take a week! So for a week customer service had no phones...needless to say I was never allowed to touch the phone switch again :(
Another one not related to software; I dropped Xeon chip while adding another cpu to existing server. I send it back to retailer. At first, they refused to accept it but when my boss twisted their hand, they agreed to forward it to OEM / Intel. We have large account with them for suppling printers and computer hardware. Finally, after 3 weeks later they send us a new boxed pack cpu...heh

Oh and the worst part about software mistake is,, someone ask you to investigate the matter (your own mess) and report it on to boss..it is fun. Usually, I end up dumping on users or hardware and/or ghosts... :r
vivek said:
Oh and the worst part about software mistake is,, someone ask you to investigate the matter (your own mess) and report it on to boss..it is fun. Usually, I end up dumping on users or hardware and/or ghosts... :r

Is that ectoplasm on your keyboard or are you just happy to see me?

...sorry that just sprang into my mind.
Getting a bit annoyed because I couldn't work out if the 0 in a hex wep key was a 0(zero) or O(letter) but then I realized that there could be no O(letter) in hex!!.

There was 4 of them in the key and I was trying out every combination haha
I could picture that being highly annoying, worst mistake I had made was deleting a photographers pictures of weddings that was a fun night of data recovery lasting till 4am.

I have a LONG list of errors by others including some woman who washed the inside of her computer with warm soapy water, it's a little long so I will save it for another day.
I had a customer whose web/mail server had been somehow (not by me) turned into an open relay. He called me to correct it, and in my haste to fix the problem, a couple important emails got deleted. :(

Free advice -- don't ever tinker with qmail's mail queue while qmail is running.

Two things came out of that muck up:
  1. I bought The qmail Handbook by Dave Sill
  2. That customer has not spoken to me in awhile
Rebooted a production server when I thought I was on my personal PC because I couldn't figure out why my flash drive didn't appear when I plugged it in. (Stupid KVMs... ;) )

When in college and doing an assembler project at home, somehow nuked the partition table of my hard drive and corrupting the running DOS, preventing me from copying anything off. No idea what I did either, since the assembler program was stored on said drive...

Corrected a college instructor, in class, and in front of everybody. I was right - the flowchart of the program we were supposed to write wasn't efficient. My program, built the way I told him to do it, ran several orders of magnitude faster than everybody elses. He didn't appreciate it though, even though I was respectful.

Different instructor, whom I had almost no respect for, told us to turn off our monitors so he could lecture. "You can still work on your program, but your monitor has to be off." he said. Well, I clicked syntax checking off in QuickBasic, turned off my monitor, and kept coding. :) He was royally POed because I wasn't listening to him blather on about crap I already knew (I knew more about QB than the instructor did by far), but I simply told him that I was only doing what he said we could do. ;)

Spent an entire semester re-writing an instruction manual for an independent study in college. (Last required class and it wasn't offered otherwise.) Ran my PC without a UPS. Power went out *just* as WP/DOS was doing it's backup - corrupted both the original and the backup.

(QuickBasic, WP for DOS... I'm showing my age, aren't I?)

While modding my home PC, I took a molex off the power wire, sleeved the cables, and put it back on. Plugged everything in and couldn't figure out why my new DVD burner ($165 at the time) didn't work. Took my machine apart and made certain everything was seated well. Wondered about the odd smell, but didn't worry about it. Went back and played with windoze 95, trying to get it to work. Finally the smell got so bad I *had* to pay attention to it. Turns out that when I re-connected the molex, I transposed the 5 volt and 12 volt wires; the smell was the chips on the logic board of my DVD burner melting. (Literally, melting. Took it apart afterwards and looked like it'd been boiling on the logic board.)

Tried to wire something hot at work so 20 people wouldn't be idle. A wire nut in the bottom of 8" deep box fell off, exposing several wires that wouldn't reach up. Shut down all the machines, killed the circuit, tested everything with my multimeter to verify it was 100% dead. Reached in and started re-connecting the wires and got zapped. The 20 people on the other side of the room on a completely different circuit all went down and 15 of those needed new PSUs. (STILL can't figure out how the building is wired, nor how everything registered as 0 volts and I still got zapped or how changing something on one circuit that was turned off affected another circuit, so much so that it killed 75% of the power supplies in the machines on that circuit...)

Laughed out loud to the VP of operations at my last job. He wanted to buy a new compound bow for hunting that fall and was looking online at work. Suddenly he jumped up and literally ran out of the building. He was headed to the admin building to tell the guy who did nothing but monitor what people were doing online (yeah - they were that bad) that he did NOT intend to access what he did. FYI, for anybody interested, <4-letter censored shorthand for Richard starting with d, ending with k, with ic in the middle>s-dot-com is !!NOT!! <shorthand for Richard>s Sporting Goods... ;) :D I could not stop laughing about it and he tried to get my fired.
Ran # rm -rf on the wrong directory a dozen times. On many occasions I nearly typed my password on an IRC channel (I use screen and I often switch to the wrong one).
I was just getting into Linux and playing with various distros. I had a Slackware system setup, and was editing stuff in /etc. I noticed the "file~" files, and wanted to remove them, so I typed "rm *~" only without the tilde.

It hosed the installation (obviously) and since I had no backups, I was hooped. I took the opportunity to install FreeBSD, loved it, and here I am on FreeBSD forums telling the story 9 years to the month later.
Was trying to change ownership of all the files in a directory, instead of:
# chown arcanius *

I did

# chown arcanius /*

Didn't end well. Was too lazy to figure out if fixable, so I just reformatted.


Staff member
@dennylin93: You'd be a good candidate for tcsh's # set rmstar ;)
dennylin93 said:
Thanks! Excellent feature. Now I won't delete the wrong files by accident. Perhaps I should alias # rm to # rm -i as well.

I would strongly advise against it. What happens when you get used to being asked for confirmation, getting sloppy in the process, and then end up at an important machine where this alias is not set. Bye-bye important system files.
I've aliased rm to "just a comment". Thus I have
to type the full path
/bin/rm -iv
and use -iv out of habit since first installing Freebsd
after reading warnings.
That extra second or two of typing means one has
enough time to think to oneself about "really what I
want to type? " I would be very leery of reverting to
non-aliased usage ever...
Interesting one came across my desk today, a guy who considers himself a Techie calls me up and says "Help I have got a virus now my computer wont boot" so i tell him to bring it to me and I ask what happened well AVG wouldn't shift the infection so he read about highjack this ran it deselected everything and restarted... oh but it gets worse... I don't know how fammilure you are with the concept of a Car Boot Sale well there is always a number of stalls selling CD's with things on like "10 thousand PC drivers" or "Watch SKY TV ON YOUR PC FOR FREE" or the best one "FIX YOUR OWN COMPUTER WITH ONE CD" normally it's nothing more than AVG, CCleaner, Double driver etc on a CD well some one was selling BartPE at one evidently and this supremely intelligent individual some how managed to delete his C: partition.