Dual head GeForce card

DarkNuker

Member


Messages: 22

As stated in the title, I have a GeForce FX 5200 dual head graphics card. The card is working just fine as is the system. My only issue is I'm trying to get the heads to work together, but because it's the same card, when I put in the BusID for the card (Card0=head, Card1=head), I get the error "NV: More than one matching Device section for instances (BusID: PCI:1:0:0) found: Card1". The X server and gnome both work just fine, but they only work on one monitor. The second monitor does show some color...but it only shows like 2 or 3 colors across the screen. That tells me that the monitor is getting a signal connection, but I now must figure how to deal with the BusID's so both monitors can be properly detected. Anyone know how to make the heads work together? What should I do with the BusID?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

AFAIK the standard Xorg nv driver doesn't support dual head.

If you want to use both outputs you will need to use the binary nvidia driver x11/nvidia-driver (it only works on i386 though).

(I've got it running on a single 7600 card with 2 1600x1200 monitors attached to it)
 
OP
D

DarkNuker

Member


Messages: 22

I installed the nvidia driver using the ports, and now get one monitor that works and the second screen full of colors but it's not an image..the image is trying to go through, but not quite there. In my xorg file, should I have each head for the graphics card labeled? Card0,1..Monitor0,1...etc? I'm trying to get two independent monitors. If I can't do that using a dual head graphics card, can I do it using one head of the graphics card and using the head on my motherboard? I have an asus motherboard. My system does have an automatic driver already installed for it, but I'm not sure if that driver would support what I'm trying to do.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

Here's my xorg.conf:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
    FontPath        "/usr/local/lib/X11/fonts/OTF/"
    FontPath        "/usr/local/lib/X11/fonts/bitstream-vera"
    FontPath        "/usr/local/lib/X11/fonts/webfonts/"
    FontPath        "/usr/local/share/ghostscript/fonts/"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "MSI"
    BoardName      "NX7600GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    #Option        "DisableGLXRootClipping" "True"
    #Option        "AllowGLXWithComposite" "True"
    Option         "TwinView"
    Option         "MetaModes" "1600x1200,1600x1200;1280x1024,1280x1024;1024x768,1024x768;800x600,800x600"
    Option         "TwinViewXineramaInfoOrder" "DFP,CRT"
    #Option        "ConnectedMonitor" "DFP"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600"
    EndSubSection
EndSection
 
OP
D

DarkNuker

Member


Messages: 22

That's a very basic layout. Mine is much fuller than that. I notice for your driver you are actually using the "nvidia" driver. I'm using the "nv" driver. How did you manage to get the actual "nvidia" driver working? I already went through the ports and installed the nvidia-driver-173xx because it's the latest one in the ports, but I'm still using the "nv" driver. It didn't change it.
 

adamk

Daemon

Reaction score: 266
Messages: 1,622

DarkNuker said:
That's a very basic layout. Mine is much fuller than that. I notice for your driver you are actually using the "nvidia" driver. I'm using the "nv" driver. How did you manage to get the actual "nvidia" driver working? I already went through the ports and installed the nvidia-driver-173xx because it's the latest one in the ports, but I'm still using the "nv" driver. It didn't change it.
Did you actually change the Driver line in your /etc/X11/xorg.conf file?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

Adamk is right, you need to change that line, the port doesn't do that for you.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

DarkNuker said:
That's a very basic layout. Mine is much fuller than that.
That because I removed all the unnecessary stuff from it :e
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,964
Messages: 11,354

DarkNuker said:
... installed the nvidia-driver-173xx because it's the latest one in the ports ...
No, it's not, x11/nvidia-driver is (currently v. 185.18.29). The numbered ones are for older NVIDIA chipsets (which you may have, but it's not the latest driver in ports).
 

adamk

Daemon

Reaction score: 266
Messages: 1,622

While you are technically correct that 185.18.29 is the latest in ports, the 173.xx driver is the latest one in ports for his GPU.

Adam
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,964
Messages: 11,354

Ok. Just wanted to make sure there wouldn't be a run on 'the latest nvidia driver in ports' due to a lack of important detail ;)
 
OP
D

DarkNuker

Member


Messages: 22

Ok, well not sure exactly how I did it, but I managed to get both monitors to work independently. I'm using one head from my geforce card and the head from my asus motherboard. And, I'm still using the "nv" driver because I never changed it. I did manually change it at one point to "nvidia", but got an error (don't remember what it was) so I changed it back. Also, my xorg file is fuller because I manually added more to properly setup my dual configuration. If you have a single monitor, your xorg file will be small. And if you have a single monitor, you technically don't even need an xorg file...atleast not in FreeBSD. Unsure of Open, NetBSD. But anways, thanks for the hep guys. I appreciate it.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,332
Messages: 33,894

DarkNuker said:
If you have a single monitor, your xorg file will be small.
See post #2
 
Top