Solved Drivers auto-loading

Buck

Member

Reaction score: 2
Messages: 30

Howdy folks.

I don't remember that happening on 11.x but now that I've upgraded to 12 I see that some drivers try to (successfully) auto load and they're not being compiled into the custom kernel and not present in /boot/loader.conf. In fact, I specifically tried to set xxx_load="NO", that didn't change anything.

So specifically in /var/log/messages,
Code:
kernel: iwm0: <Intel(R) Dual Band Wireless AC 7265> mem 0xfe600000-0xfe601fff irq 34 at device 0.0 on pci9
kernel: iwm0: hw rev 0x210, fw ver 22.361476.0, address 34:f6:4b:34:91
kernel: intsmb0: <AMD FCH SMBus Controller> at device 20.0 on pci0
kernel: smbus0: <System Management Bus> on intsmb0
Where should I look to disable loading those?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,602
Messages: 37,927

I see that some drivers try to (successfully) auto load and they're not being compiled into the custom kernel
Perhaps you're not running a custom kernel but GENERIC instead? Post the output of uname -a.
 
OP
Buck

Buck

Member

Reaction score: 2
Messages: 30

Nope, definitely not.
FreeBSD mybsdbox 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 RYZEN amd64

devd_enable="NO"
devmatch_enable="NO"

in /etc/rc.conf fixed autoloading. I only wonder why those services autoload without me implicitly telling them to. Is there any other service that behaves in a similar fashion, i.e. there's no corresponding line in rc.conf yet it still starts?
 

b6s6d6

Member

Reaction score: 17
Messages: 38

Nope, definitely not.
FreeBSD mybsdbox 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 RYZEN amd64

devd_enable="NO"
devmatch_enable="NO"

in /etc/rc.conf fixed autoloading. I only wonder why those services autoload without me implicitly telling them to. Is there any other service that behaves in a similar fashion, i.e. there's no corresponding line in rc.conf yet it still starts?
It's not that they auto load for no reason, they do so because there's also this file: /etc/defaults/rc.conf
There you can find all the system defaults if you wanna know them 👍
 
OP
Buck

Buck

Member

Reaction score: 2
Messages: 30

Yeah, missed /etc/defaults/rc.conf. The setting is indeed there.
 
Top