dolphin ext4 automount error

tmv

New Member


Messages: 9

#1
I can manually mount ext4 partitions using ext4fuse but when using dolphin an error message appears:

Code:
An error occurred while accessing 'Home', the system responded: org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: /dev/ext2fs/data: Operation not supported by device
1) In /etc/rc.conf :
Code:
dbus_enable="YES"
hald_enable="YES"
kdm4_enable="YES"
2)
- User is in wheel and operator group.
- I have /etc/sysctl.conf vfs.usermount: 1


3) First there was permission denied problem with dolphin. I fixed that editing
/usr/local/etc/PolicyKit/PolicyKit.conf file including my user name.

Code:
<config version="0.1">
    <match user="root|user_name">
        <return result="yes"/>
    </match>
    <define_admin_auth group="wheel"/>
</config>
4) I've understand that dolphin should automount ext4 partitions automatically when using kdm4. But maybe there is something that I missed out - I think it is related something with ext2fs, same what actually error message is telling, but I cant figure out how to solve this. Any suggestions how should this work?
 
Last edited by a moderator:

aragats

Aspiring Daemon

Thanks: 362
Messages: 921

#2
I would suggest adding corresponding lines to /etc/fstab:
Code:
/dev/<dev_part_node>   /mnt/<mount_point>   ext4   mountprog=/usr/local/bin/ext4fuse,noauto,allow_other   0   0
 
OP
OP
T

tmv

New Member


Messages: 9

#3
I would suggest adding corresponding lines to /etc/fstab
Yes, of course.

Still, somehow I don't get this work proper.

Here is output of gpart show ada2 is disk what I'm trying to mount. Manually mounting works.
Code:
=>       63  625142385  ada0  MBR  (298G)
         63       1985        - free -  (993K)
       2048   97654784     1  linux-data  [active]  (47G)
   97656832       2046        - free -  (1.0M)
   97658878  527482882     2  ebr  (252G)
  625141760        688        - free -  (344K)

=>        0  527482882  ada0s2  EBR  (252G)
          0  500140034       1  linux-data  (238G)
  500140034   27342848  7938731  linux-swap  (13G)

=>       40  117231328  ada1  GPT  (56G)
         40       1024     1  freebsd-boot  (512K)
       1064        984        - free -  (492K)
       2048    8388608     2  freebsd-swap  (4.0G)
    8390656  108838912     3  freebsd-zfs  (52G)
  117229568       1800        - free -  (900K)

=>       63  625142385  ada2  MBR  (298G)
         63          1        - free -  (512B)
         64  314572800     1  linux-data  [active]  (150G)
  314572864       1984        - free -  (992K)
  314574848  310566912     2  linux-data  (148G)
  625141760        688        - free -  (344K)
And my /etc/fstab
Code:
# Device        Mountpoint      FStype  Options         Dump    Pass#
proc            /proc           procfs  rw              0       0
/dev/ada1p2     none            swap    sw              0       0
/dev/ada2s1     /mnt/apina      ext4    mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late 0  0
/dev/ada2s2     /mnt/data       ext4    mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late 0  0
Output of mount -a
Code:
fstab: /etc/fstab:4: Inappropriate file type or format
fstab: /etc/fstab:5: Inappropriate file type or format
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#4
What happens when you ignore the error and just try mounting again?
I had some time ago with one system the phenomenon that the first attempt always failed, but the second one immediately afterwards always succeeded, so it didn't bother me so much that I would have cared to look for the cause. So I cannot tell why this happened.
Maybe try this?
 
OP
OP
T

tmv

New Member


Messages: 9

#5
What happens when you ignore the error and just try mounting again?
Nothing that I would like to. Directorys stay empty. And dolphin error note this time:
Code:
An error occurred while accessing 'Home', the system responded: org.freedesktop.Hal.Device.UnknownError: fstab: /etc/fstab:4: Inappropriate file type or format fstab: /etc/fstab:5: Inappropriate file type or format
I think this problem is somehow releated to /etc/fstab. Swap partition is not mounting either.
 
OP
OP
T

tmv

New Member


Messages: 9

#7
Why DSMD would manage this job better than hal?

To me, this seems like the problem it's not related to hal. The problem might be in /etc/fstab and aspects associated with it. And because I'm pretty novice handling with FreeBSD, there might be just some minor issue which I haven't focused on.
 

mrclksr

Active Member

Thanks: 95
Messages: 129

#8
The problem might be in /etc/fstab and aspects associated with it. And because I'm pretty novice handling with FreeBSD, there might be just some minor issue which I haven't focused on.
Code:
/dev/ada2s1 /mnt/apina ext4 mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late,ro 0 0
/dev/ada2s2 /mnt/data ext4 mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late,ro 0 0
The ro-option is missing. sysutils/fusefs-ext4fuse doesn't support rw-mounting.
 
OP
OP
T

tmv

New Member


Messages: 9

#9
Code:
/dev/ada2s1 /mnt/apina ext4 mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late,ro 0 0
/dev/ada2s2 /mnt/data ext4 mountprog=/usr/local/bin/ext4fuse,noauto,allow_other,late,ro 0 0
The ro-option is missing. sysutils/fusefs-ext4fuse doesn't support rw-mounting.
Oh yes, of course. I added ro option to /etc/fstab
This time when mount -a is typed, no error message appears. But no actually mounting is done
 
OP
OP
T

tmv

New Member


Messages: 9

#11
And probably late flag too. But when I remove noauto and late flag mount -a gives:
Code:
fuse: failed to open fuse device: No such file or directory
 

mrclksr

Active Member

Thanks: 95
Messages: 129

#12
The fuse.ko module is not loaded. Load it with kldload fuse. To load fuse.ko automatically at boot time, add
Code:
fuse_load="YES"
to /boot/loader.conf
 
OP
OP
T

tmv

New Member


Messages: 9

#13
fuse.ko module is now loaded and /etc/fstab is mounting disks correctly.
I had fuse_enable"YES" on /boot/loader, which turns to be incorrect format.

And back to kde's dolphin usage. Under dolphin partitions shows under "device" section. I guess that one is not working either when clicking it.
In some proper time I will figure out why. So no specific question this time, unless there is some hint where to start looking for.
HAL-faq is readed already.
 
Top