Does FreeBSD 11 support CPU N3150?

Just about any CPU is well supported by FreeBSD. Support for the integrated GFX chips is a different matter.

I am a newbie to FreeBSD. I am considering buying or customizing a desktop PC for FreeBSD. I think that the following hardware is supported but just to make sure I would like to ask you if it is ok.

Intel Core i5-4460S (6M Cache,2,9GHz)

NVIDIA® GT720 (2GD3)

If i buy a PC for FreeBSD it will be this one (unless you tell me not to)

Id' be very grateful for any help you can offer. As I said, I am a newbie.

Thank you
CPU and even the GPU if it is NVidia which has theor commercial drivers for FreeBSD is not a problem. But the problem with hardware is that you run into problems everytime with hardware that you would least expect, so it might be a different revision of network card, or a controller that is not supported or some ACPI that is broken, whatever. You can not say that a computer with these or those specifications will run good with FreeBSD, you would need to give the exact models of the chipsets used in the computer and that is a long list for any computer. The only exceptions are things like Raspberry Pi, when you know what model, for example the B or 2, then you have an exact match you can tell if it works or does not work with FreeBSD because in each Raspberry of a specific model the same hardware is included, they do not differ from each other. But with laptops it can differ very. For example Apple MacBooks have some Atheros Wifi, some had Broadcom, and so on. Even though they were sold as the same model of MacBook.
yes cpu is supported. but gpu is not supported on intel driver yet. you can use scfb driver until intel driver supports the gpu. (for n3150)
I recently had ASRock N3150B-ITX motherboard that has this SoC.

With FreeBSD 12-CURRENT from 2017/10 (two months ago) and DRM-NEXT the x11/xorg starts in accelerated mode. In other words, GPU is supported and works well.

The problem is that the HDMI output does not work, only VGA.

The 4-core CPU works well, I had no timing issues, I used ntpd, dunno if that solves the 'timing issues', for the record, I have had enabled HPET in BIOS.

The integreted NIC - Realtek (re0) works good.

Two SATA ports work.

USB 2.0 and 3.0 worked well.

Another thing that did not worked (besides no HDMI output) was 'deaf' Mini Jack (sound output), maybe it will be 'fixable' by /boot/device.hints, havent tried, as no HDMI is enought for me to mark this board as 'no go'.

Here is the (only) config for x11/xorg:

% cat /usr/local/etc/X11/xorg.conf.d/card0.conf
Section "Device"
Identifier "Card0"
Driver "modesetting"
Option "AccelMethod" "glamor"
Option "DRI" "3"

It has been suggested that I should also install libva-intel-driver and libva-utils for smooth movies/videos playback.

Run 'vainfo' to see what video acceleration your chip supports.