• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Disappearing pkg packages? Trying to install flang (Fortran compiler)

Preetpal

Member

Thanks: 16
Messages: 94

#1
I basically wanted to install https://www.freshports.org/devel/flang/ but it appears to be unavailable although it appeared once via pkg search flang? Any suggestions (other than installing from ports (I currently am only using binary packages on this system)) would be welcome.

Code:
ps@myhostname [00:45:48 Mon Feb 05] (0)
/usr/home/ps ruby@2.5.0 $ pkg search flang
flang-5.0.20171019_2           Fortran compiler targeting LLVM
flang-clang-5.0.20171019_1     Fortran compiler targeting LLVM (modified clang part)

ps@myhostname [01:41:27 Mon Feb 05] (0)
/usr/home/ps ruby@2.5.0 $ sudo pkg install flang
Password:
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01  
Fetching packagesite.txz: 100%    6 MiB   2.1MB/s    00:03  
Processing entries: 100%
FreeBSD repository update completed. 28776 packages processed.
All repositories are up to date.
pkg: No packages available to install matching 'flang' have been found in the repositories

ps@myhostname [01:41:59 Mon Feb 05] (70)
/usr/home/ps ruby@2.5.0 $ sudo pkg install flang-5.0
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: No packages available to install matching 'flang-5.0' have been found in the repositories

ps@myhostname [01:42:08 Mon Feb 05] (70)
/usr/home/ps ruby@2.5.0 $ sudo pkg search flang

ps@myhostname [01:43:06 Mon Feb 05] (70)
/usr/home/ps ruby@2.5.0 $  pkg search flang
 

tobik@

Daemon
Developer

Thanks: 1,175
Messages: 1,769

#2
Unfortunately devel/flang-clang currently fails to build [1] [2] on the quarterly branch. An update to devel/llvm50 was merged to it on 2018-02-02 without checking if packages fail to build because of it. IMHO this shouldn't have been done. I've notified the maintainer and responsible committer and hopefully the package will be available again soon.

You could switch to using latest packages in the meantime. [3] explains how.

[1] http://beefy3.nyi.freebsd.org/data/...08/logs/errors/flang-clang-5.0.20171019_1.log
[2] http://beefy2.nyi.freebsd.org/data/...08/logs/errors/flang-clang-5.0.20171019_1.log
[3] https://forums.freebsd.org/threads/52843/#post-296554
 

Preetpal

Member

Thanks: 16
Messages: 94

#3
Unfortunately devel/flang-clang currently fails to build [1] [2] on the quarterly branch. An update to devel/llvm50 was merged to it on 2018-02-02 without checking if packages fail to build because of it. IMHO this shouldn't have been done. I've notified the maintainer and responsible committer and hopefully the package will be available again soon.
Was this done via a public observable channel (like https://bugs.freebsd.org/bugzilla/)? I wondering this in case I want to report issues in the future.