Disabling acpi when booting from iso?

Melvin Stark

New Member


Messages: 16

I'm attempting to boot from a FreeBSD 11.2 DVD iso and receive never-ending acpi errors. How do I disable acpi?
I've tried entering 'unset acpi_load' from option 3 without success.
 

Phishfry

Son of Beastie

Reaction score: 1,156
Messages: 3,304

You have your loader setting wrong. Try this:
[BGCOLOR=rgb(239, 239, 239)]set acpi_load="NO"[/BGCOLOR]

The manual seems to indicate a hint is needed instead as I do not see your setting:
[BGCOLOR=rgb(239, 239, 239)]hint.acpi.0.disabled[/BGCOLOR]
https://www.freebsd.org/cgi/man.cgi?acpi(4)
 
OP
OP
M

Melvin Stark

New Member


Messages: 16

Thank you, but I'm still having problems. I've tried set acpi_load="NO" followed by 'boot' at the OK prompt. Is that correct? I've also tried the command with a lower-case "no".

After trying both I still receive endless ACPI errors. I see older versions of BSD offered a "Boot BSD with ACPI disabled" option but that's apparently no longer available.
 
OP
OP
M

Melvin Stark

New Member


Messages: 16

I found 'boot -m' allows me to boot. I tried that before posting but assumed it didn't work as I was taken to the mascot/logo page, which never progressed. However, I downloaded 13 and waited - success. It may also have worked with 11.2 had I waited longer.
 
Top