disable LDVS1

Howdy all, my first post.
Quick rundown, I use FreeBSD 10.3 Openbox minimal install as per taz for a long time. However, after I broke my laptop screen so connected a monitor and configured that in xorg.conf fine, however running xrandr my ldvs1 is still running and sort of overlays the resolution (1400x1024) over my vga1 monitor (1440x900) so my mouse can move an inch past the bottom of my screen(plus taskbar is down there but unseen)
the fix is "xrandr --output LVDS1 --off"
however to make permanent I have put it in .xinitrc as per the FreeBSD instructions but it doesn't seem to apply it.

Can anyone point myself in the correct direction please.
 
Can you post your current xorg.conf? The internal monitor screen may still be defined causing the system to extend the display to both monitors.
 
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/share/fonts/misc/"
   FontPath     "/usr/local/share/fonts/TTF/"
   FontPath     "/usr/local/share/fonts/OTF/"
   FontPath     "/usr/local/share/fonts/Type1/"
   FontPath     "/usr/local/share/fonts/100dpi/"
   FontPath     "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/sysmouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   HorizSync    30-83   # kHz
   VertRefresh  50-76   # Hz
EndSection


Section "Monitor"
   Identifier   "Monitor1"
   HorizSync    30-83   # kHz
   VertRefresh  50-76   # Hz

EndSection



Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"               # <i>
        #Option     "VideoKey"               # <i>
        #Option     "Tiling"                 # [<bool>]
        #Option     "LinearFramebuffer"      # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"           # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"         # [<bool>]
        #Option     "XvMC"                   # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"               # [<bool>]
        #Option     "PerCrtcPixmaps"         # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"      # [<bool>]
        #Option     "DebugFlushCaches"       # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection



Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor1"
   SubSection "Display"
       Viewport   0 0
       Depth     24
       Modes   "1440x900"
   EndSubSection
EndSection

Section "Screen"
       Identifier "Screen1"
       Device   "Card0"
       Monitor   "monitor0"
       SubSection "Display"   
       Viewport 0 0
       Depth  24
       Modes  "1440x900"   
   EndSubSection
EndSection
 
Right, you have both screens defined and enabled. Remove Screen1 and Monitor1. Don't forget to also remove the reference to Screen1 from the ServerLayout section.
 
Okay, removed the excess lines from xorg.conf however the problem still exists after reboot. I added the modified xorg.conf

Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/share/fonts/misc/"
   FontPath     "/usr/local/share/fonts/TTF/"
   FontPath     "/usr/local/share/fonts/OTF/"
   FontPath     "/usr/local/share/fonts/Type1/"
   FontPath     "/usr/local/share/fonts/100dpi/"
   FontPath     "/usr/local/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/sysmouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   HorizSync    30-83   # kHz
   VertRefresh  50-76   # Hz
EndSection


Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"               # <i>
        #Option     "VideoKey"               # <i>
        #Option     "Tiling"                 # [<bool>]
        #Option     "LinearFramebuffer"      # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"           # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"         # [<bool>]
        #Option     "XvMC"                   # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"               # [<bool>]
        #Option     "PerCrtcPixmaps"         # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"      # [<bool>]
        #Option     "DebugFlushCaches"       # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection



Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
       Viewport   0 0
       Depth     24
       Modes   "1440x900"
   EndSubSection
EndSection
 
Output of xrandr, if it helps at all.

Code:
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1792x1344     60.01 
   1600x1200     60.00 
   1400x1050     59.98 
   1280x1024     60.02 
   1280x960      60.00 
   1024x768      60.00 
   800x600       60.32    56.25 
   640x480       59.94 
VGA1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900      59.89*+
   1280x1024     75.02    60.02 
   1280x960      60.00 
   1152x864      75.00 
   1152x720      59.97 
   1024x768      75.08    60.00 
   832x624       74.55 
   800x600       75.00    60.32 
   640x480       75.00    60.00 
   720x400       70.08 
DP1 disconnected (normal left inverted right x axis y axis)
 
however to make permanent I have put it in .xinitrc as per the FreeBSD instructions but it doesn't seem to apply it.
How do you start Openbox? Can you show your .xinitrc? Have you tried adding the xrandr command to ~/.config/openbox/autostart.sh?
 
Thank you tobik, you are a legend! ... its sorted following your idea. For anyone else that needs help I have posted my autostart.sh
Code:
#!/bin/sh
xrandr --output LVDS1 --off
(sleep 2 && tint2) &
(sleep 2 && wbar) &
feh --bg-scale ~/wallpaper/wallpaper1.jpg &

marko
 
Back
Top