MATE Disable gnome-keyring-daemon in Mate

rmelcer

New Member


Messages: 1

#1
I'm running Mate 1.8.1 on FreeBSD 10.1-RELEASE-p5 and I'd like to use security/keychain instead of gnome-keyring-daemon for ssh key management. Currently, gnome-keyring-daemon is starting when I log into Mate and overriding ssh-agent. I've had this work previously in x11/gnome2 on FreeBSD 9. I'd prefer not to remove/disable gnome-keyring-daemon completely so I can use its other functionality.

What I've tried so far:

I've disabled all instances of gnome-keyring-daemon within mate-session-properties (Startup Applications), which is what Google recommends repeatedly. I have also chmod 0 /usr/local/etc/xdg/autostart/gnome* to verify that gnome-keyring-daemon isn't being started from there either.

I restarted the workstation with auditd enabled using a flags and naflags value of
Code:
ex,fr,ot,pc
which gave me the following relevant entries:
Code:
header,86,11,fork(2),0,Fri Mar  6 15:01:25 2015, + 319 msec
argument,0,0x58a,child PID
subject,-1,rmelcer,users,rmelcer,users,1406,0,0,0.0.0.0
return,success,1418
trailer,86
<snip>
header,170,11,execve(2),0,Fri Mar  6 15:01:25 2015, + 325 msec
exec arg,gnome-keyring-daemon,--start
path,/usr/local/bin/gnome-keyring-daemon
attribute,755,root,wheel,739241656,170551,2156730368
subject,-1,rmelcer,users,rmelcer,users,1418,0,0,0.0.0.0
return,success,0
trailer,170
Which reads to my (admittedly untrained) eye as: gnome-keyring-daemon was started by PID 1418, which was originally forked from PID 1406. And 1406 is:
Code:
[smelter /var/audit]# ps -j -p 1406
USER     PID PPID PGID  SID JOBC STAT TT     TIME COMMAND
rmelcer 1406  828 1406 1406    0 Is    -  0:00.07 /usr/local/bin/mate-session
I have also rebooted and logged in while gnome-keyring-daemon was chmod 0, so I know nothing weird is being caused by root.

I don't see any schemas in gsettings list-schemas that seem to have anything to do with keyrings.

My conclusion is that mate-session is starting gnome-keyring-daemon by itself (as opposed to through user settings), which is neither desired nor expected behavior. It also seems like this is FreeBSD specific behavior, since others 'round the net have successfully disabled it via the Startup Applications method.

Does anyone know something else I can try, or maybe why mate-session is starting gnome-keyring-daemon?

Thanks in advance!
 
Top