Xfce Desktop wallpaper and menu got broken after XFCE upgrade

sir_dog

New Member

Reaction score: 1
Messages: 19

Yesterday I updated packages on my home PC (12.2-STABLE 3cc3872829b amd64) via pkg upgrade, XFCE version got changed from 4.14 to 4.16 and my desktop stopped working properly. My custom wallpaper disappeared and I only have black screen on all virtual workplaces, there no reaction on desktop mouse click, menu doesn't appear (either with right mouse button or middle mouse button click). I looked in settings manager, there are no changes there. I tried to change the wallpaper, set another file from another directory, set .PNG file instead of .JPG but had just the same. Is there any way to bring desktop menu and wallpaper back or at least how can I investigate what went wrong? I tried to google the problem but found nothing like that.
 

Alexander88207

Aspiring Daemon

Reaction score: 355
Messages: 580

Hello,

have you tried to reset your XFCE settings?

You can do that with:

rm -r /usr/home/$USER/.config/xfce4
 

Waldin

New Member


Messages: 3

Hi. Something similar happened to me. After updating the system and XFCE, in one of the messages I read that the libexo package had to be reinstalled. Specifically something like this: pkg install -f libexo I opened a virtual console, and after that command, I rebooted the system and XFCE returned to working normally.
 

Geezer

Well-Known Member

Reaction score: 162
Messages: 340

have you tried to reset your XFCE settings?
rm -r /usr/home/$USER/.config/xfce4
No that does not work.

Quite a few things in 4.16 just don't work:
Plugin "Application Menu" unexpectedly left the panel...
And many others including the display settings.

Looks like 4.16 is a bit premature. Looking forward to 4.16_and_a_bit_more.
 

Alexander88207

Aspiring Daemon

Reaction score: 355
Messages: 580

I had a few days ago XFCE 4.16 from the latest packages fresh set up and everything has worked.

What if you re-install all packages?

I assume that you use the matapackage x11-wm/xfce4


pkg remove x11-wm/xfce4
pkg autoremove
pkg install x11-wm/xfce4
 

Geezer

Well-Known Member

Reaction score: 162
Messages: 340

Just tried that as well. And deleted .config/xfce4.

On first use of desktop I get a similar error messages, Plugin "Directory Menu" unexpectedly..., Plugin "PulseAudio Menu" unexpectedly..., Plugin "Windows Buttons" unexpectedly..., Plugin "Application Menu" unexpectedly....

New theme is a bit drab, but what really matters is, it don't work.
 

Columbo0815

New Member

Reaction score: 2
Messages: 13

Try pkg upgrade -f libexo (see UPDATING). Too bad, pkg updating isn't usable without ports (or downloading /usr/ports/UPDATING manually) :'‑(
 

Geezer

Well-Known Member

Reaction score: 162
Messages: 340

pkg deleted libexo and everything with xfce in it, all the plugins and everything.

Then pkg installed it all again.

Same thing. Don't fully work.
 

Waldin

New Member


Messages: 3

pkg deleted libexo and everything with xfce in it, all the plugins and everything.

Then pkg installed it all again.

Same thing. Don't fully work.
It's strange. When updating XFCE to version 4.16 and rebooting the system, some plugins crash. The solution that worked for me was:
1. Remove the plugins that fail from the panels.
2. Execute the command: pkg upgrade -f libexo
3. Reboot the system
4. Add the plugins to the panels again.
 

Geezer

Well-Known Member

Reaction score: 162
Messages: 340

Deleted xfce, libexo, all plugins and goodies and everything with xfce in it.
Autoremoved all dependencies.
Jumped up and down, had a cup of tea.
Incrementally reinstalled xfce and all the plugins.

Now it works ... mostly.
All the pluggins appear to work, all the settings are accessible including the settings for the desktop.

But the desktop is still black. Can't get anything to appear on it, no background picture, no single colour, no icon.
Not nothing. Black.

All the programs run, so it is usable. Just got a black background.
 

facedebouc

Member

Reaction score: 7
Messages: 46

I am using quarterly packages and since 2021Q1 got similar problems with Xfce.
It's recurrent at each quarterly, xfce has something dysfunctional. So I returned to my favorite WM: x11-wm/fvwm.
It's not feasible for my other users whose have habits with Xfce.
 
OP
sir_dog

sir_dog

New Member

Reaction score: 1
Messages: 19

I got the desktop functional again. Tried do reinstall all the xfce-* packages plus libexo - it didn't help, even after reboot. Then I moved ~/.config/xfce4 to another location and rebooted the system to have desktop environment work from scratch. It didn't help again. I desperately tuned XFCE settings in order to make them tuned the same as I'd had them before the failure happened, rebooted - and had my desktop looking and working as I expected from him to do. I compared actual and backed up settings, they're the same in sections, related to wallpaper and desktop menu. So now I have rather fully working DE (some features I had to tune from scratch, like the system button and the programs buttons applet), but can't understand how it was sorted out.
 

rootbert

Well-Known Member

Reaction score: 148
Messages: 400

I could not work it out to have a working desktop ... deleting the config, installing from scratch did not help. using mate now since I need a working desktop
 

elscripto

New Member

Reaction score: 1
Messages: 15

I confirm the Xfce 4.14-->4.16 breakage beyond repair too.
One bare metal install and one virtual machine devastated.
Had to revert the upgrade from a snapshot and a backup accordingly.
Just curious, does QA test these massive changes in desktop major versions?
 
OP
sir_dog

sir_dog

New Member

Reaction score: 1
Messages: 19

Thanks. So then QA do test.
However I see at the provided link two blockers and a missing review.
Then I guess I will wait approvals to happen there before my next attempt for an upgrade.
I hope that changes they'll made before approvals won't break my for-some-unknown-reason-working desktop.
 

Geezer

Well-Known Member

Reaction score: 162
Messages: 340

I've found it. I think.

Done adduser and the desktop works, so something somewhere in the configuration is stopping the desktop working for existing users.

Incrementally went through and found it.

Deleted the contents of ~/.cache/sessions and now it all works. I think it was xfce4-session-hostname:0
 

Waldin

New Member


Messages: 3

Today I have installed updates to some XFCE version 4.16 packages. I do not know if it is to solve the problems mentioned here. Specifically these:

[1/6] Upgrading libtasn1 from 4.16.0 to 4.16.0_1...
[2/6] Upgrading xfce4-wm from 4.16.0 to 4.16.1...
[3/6] Upgrading xfce4-settings from 4.16.0 to 4.16.0_1...
[4/6] Upgrading sudo from 1.9.4p2 to 1.9.5...
[5/6] Upgrading llvm10 from 10.0.1_4 to 10.0.1_5...
[6/6] Upgrading greybird-theme from 3.22.13 to 3.22.14...
 

elscripto

New Member

Reaction score: 1
Messages: 15

Attempted a new 4.14-->4.16 update today, there are some new package versions, but the same mess happens. The result again is a broken desktop in many aspects.
I give up on Xfce, I've purged Xfce at all and installed the simplistic Lxqt on my desktops in a final 3d attempt to use FreeBSD as a desktop replacement for a Linux desktop. Lxqt works perfectly fine for now and I sincerely hope it will not be labeled soon best-effort-attempt as Gnome3 was and now Xfce obviously is.
 
Top