Dell Wireless 1395 (BCM94312MCG) doesn't work right under FreeBSD 12

angrybliss

New Member


Messages: 2

I've stayed up all night just trying to make it work. I've finally figured out how to compile the b43-fwcutter driver and modify rc.conf, loader.conf, and wpa_supplicant.conf. It works after the first reboot, but the second time, the driver keeps "restarting" as far I can tell. The Wi-Fi indicator keeps blinking where it should stay solid. Of course, the Internet is down again.


Here are my history:

40 sudo pkg install bwn-firmware-kmod

41 sudo pkg install portmaster

42 sudo pkg install b43-fwcutter

43 sudo portmaster sysutils/b43-fwcutter net/bwn-firmware-kmod

44 sudo nano

45 sudo nano /boot/loader.conf

46 clear

47 nano /etc/rc.conf

48 sudo nano /etc/rc.conf

49 clear

50 nano /etc/wpa_supplicant.conf

51 sudo nano /etc/wpa_supplicant.conf

52 sudo nano /etc/wpa_supplicant.conf

53 sudo reboot


and here's ifconfig after:

wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

ether ---------------------

groups: wlan

ssid "" channel 40 (5200 MHz 11a)

regdomain FCC country US authmode OPEN privacy OFF txpower 17 bmiss 7

mcastrate 6 mgmtrate 6 scanvalid 60 wme

media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)

status: no carrier

nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
 

Attachments

Elazar

Member

Reaction score: 28
Messages: 55

Can you show the contents of your /etc/rc.conf file, especially the ifconfig_ and wlans_ settings?
Did you make an entry in your /etc/wpa_supplicant.conf file?

This is the handbook section on setting up your network card:
 
OP
OP
angrybliss

angrybliss

New Member


Messages: 2

Can you show the contents of your /etc/rc.conf file, especially the ifconfig_ and wlans_ settings?
Did you make an entry in your /etc/wpa_supplicant.conf file?

This is the handbook section on setting up your network card:
I end up not to install on that machine and went another one (HP Mini 2133) instead. This time I had two wireless cards, an Apple AirPort (BCM4312) and its original HP module (BCM4311). The first one result in a kernel panic and the OS stuck in a loop, while the other one boots, I still can't establish the connection.

What I've done is follow through this guide: https://basicbsd.wordpress.com/2018/01/28/broadcom-bcm4312-wireless-network-card-on-freebsd-11-1/

here's my /boot/loader.conf:

Code:
security.bsd.allow_destructive_dtrace=0
siba_bwn_load="YES"
if_bwn_load="YES"
bwn_v4_lp_ucode_load="YES"
/etc/rc.conf:

Code:
clear_tmp_enable="YES"
hostname="Megahertz"
ifconfig_bge0="DHCP"
local_unbound_enable="YES"
sshd_enable="YES"
moused_enable="YES"
ntpdate_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
dbus_enable="YES"
hald_enable="YES"
slim_enable="YES"
wlans_bwn0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
I wouldn't leak my Wi-Fi SSID and SPK, but pretty much the same with the guide.

/etc/wpa_supplicant.conf:

Code:
network={
        ssid="**"
        psk="**"
}

Speaking of ifconfig, I noticed that my wlan0 SSID is empty:
Code:
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=8009b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,LINKSTATE>
    ether ***
    inet 192.168.20.13 netmask 0xffffff00 broadcast 192.168.20.255
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
    groups: lo
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether ***
    groups: wlan
    ssid "" channel 2 (2417 MHz 11g)
    regdomain FCC country US authmode WPA1+WPA2/802.11i privacy MIXED
    deftxkey UNDEF txpower 30 bmiss 7 scanvalid 60 protmode CTS wme
    roaming MANUAL bintval 0
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
 
Top