Dell Latitude E6530 recommended

jalla

Well-Known Member

Reaction score: 85
Messages: 385

Just got this machine and installed 9-Stable. I'm happy to say that everything of importance seems to work, including suspend/resume[1]

Apart from the obvious:

- Networking (wired and wireless) work out-of-the-box and lagg(4)() failover is flawless.
- Graphics card (NVS 5200M) is supported by the x11/nvidia-driver (Optimus must be disabled in bios)
- Camera works with multimedia/webcamd (mic is untested, but I'd be surprised if that doesn't work)
- Sound over HDMI works (sysctl hw.snd.default_unit=3)
- SDCard reader is supported (load kernel modules sdhci(4)(), mmc(4)(), and mmcsd(4)())

[1] Resume works only when X is running. In text-mode the screen remains dead after resume. (I've tried to set sysctl hw.acpi.reset_video=1 which doesn't help)
 
OP
OP
jalla

jalla

Well-Known Member

Reaction score: 85
Messages: 385

The wireless is Intel Centrino Ultimate-N 6300. It's supported by iwn(4)
 
Last edited by a moderator:

bald_bohemian

New Member


Messages: 14

I have an Nvidia NVS 5200M graphics card. Running the lspci command under Debian also shows an Intel 3rd gen graphics controller.
 

sens

New Member


Messages: 8

hmm...it must works fine

your load nvidia and nvidia-modeset modules?

may you show
/var/log/Xorg.0.log?
 

Phishfry

Son of Beastie

Reaction score: 1,402
Messages: 4,125

For Dell E6430 with Nvidia 5200M (Same computer 14" screen)

pkg install nvidia-driver nvidia-settings nvidia-xconfig

add to /etc/rc.conf
Code:
kld_list="nvidia-modeset"
add to /boot/loader.conf
Code:
linux_load="YES"
nvidia_load-"YES"
Reboot and try nvidia settings in the control panel. It may prompt you to run nvidia-xconfig.
 

tankist02

Well-Known Member

Reaction score: 43
Messages: 308

Did you enable two-finger scrolling? I tried to use synaptics driver, but did not succeed.
 
Top