Solved Cyrillic characters showing as question marks.

beast1e

Member

Reaction score: 2
Messages: 24

I have an issue with cyrillic file names. They appear as question marks. I don't know how to fix it. Any ideas?
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

I tried installing the fonts and they are all installed already. I ran the fc-cache command though, but the same! Still question marks. I tried downloading something else with cyrillic title, the same issue and on top of that when I tried to open the file still, it says... pdf does not exist. It does the same with spanish titled file. As if the file doesn't exist.
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

I have an issue with cyrillic file names. They appear as question marks. I don't know how to fix it. Any ideas?
Where? Console, terminal, X/graphics? What are your locales?

[EDIT]

If you want full Russian cyrillic support the first thing to do is switching your user "Class" to russian (see /etc/login.conf for details).

chsh $USER and modify the Class.

For X fonts you may need to add then to Xorg.conf or font specific file. Something like this:

Section "Files"
FontPath "/usr/share/fonts/local/"
FontPath "/usr/local/share/fonts/cyrillic"
FontPath "/usr/local/share/fonts/ohsnap"
FontPath "/usr/local/share/fonts/terminus-font"
EndSection

Btw, x11-fonts/terminus-font have cyrillic support.

For X it depends on how you configure it but adding the locales to .xinitrc may be enough:

LANG=ru_RU.UTF-8
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

Dolphin file manager, precisely. Region settings are set to "Default".
Ah, I think you just have Cyrillic support with bitmaps fonts and these may be disabled on fontconfig. Try installing and setting the Noto fonts to see if the cyrillic characters show up, then we can address the bitmap fonts if necessary.
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

Ah, I think you just have Cyrillic support with bitmaps fonts and these may be disabled on fontconfig. Try installing and setting the Noto fonts to see if the cyrillic characters show up, then we can address the bitmap fonts if necessary.
I already am using Noto Sans font by default. How do you access fontconfig?
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

I already am using Noto Sans font by default. How do you access fontconfig?
I think the Noto has cyrillic support on basic, you may want to try x11-fonts/paratype. Btw, the "PT Fonts" were designed to have the best cyrillic support.

For fontconfig you need to either enable bitmap fonts on /usr/local/etc/fonts or enable specific fonts on .config/fontconfig/.fonts, but I cant give you the syntax now (but there are examples on the forum); however this fontconfig configuration just affect bitmap fonts.

[EDIT] you probably don't want full bitmap support because you are quite likely to get some down ugly fonts on Firefox (search on the forum).
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

Thank you for your help!! I am kind of stuck. I installed the paratype fonts but I don't know how to set it. After installation it asks me to do that -
To use these fonts, add the following line to the "Files" section of
xorg.conf:

FontPath "/usr/local/share/fonts/ParaType/"
But I don't have xorg.conf and so I have no idea where to create it.
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

Thank you for your help!! I am kind of stuck. I installed the paratype fonts but I don't know how to set it. After installation it asks me to do that -
To use these fonts, add the following line to the "Files" section of
xorg.conf:

FontPath "/usr/local/share/fonts/ParaType/"
But I don't have xorg.conf and so I have no idea where to create it.
You just need to add it for bitmap fonts, the Paratype ones are .ttf and should work automatically on graphic interfaces. :-/

The Paratype fonts are called "PT Fonts" and you can get them directly from the Paratype site too (PT Public Pack).

I am out of ideas of why the Cyrillic characters are not showing up. Try running fc-cache -frEv to see what happens.
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

Assuming you are using KDE (Dolphin), and if none of this work ask on IRC (Freenode #kde-freebsd). Also, there are at least one Russian folk who hang in there (but this is unlikely to have a lot of activity at this hour). :)
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

I tried running fc-cache -frEv, but it says..
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: failed
I tried switching to Paratype fonts from settings and so I switched to it completely, and the issue persists. Yes, I am using KDE. What baffles me most is that it refuses to open the files.
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

Don't run it as root! Are you using the system as root?
Oops... no, I am not running the system as root. I know it's a big no-no. I did run the command as root since I assumed it would ask for superuser privileges! But the issue is fixed. I changed my region to a cyrillic country and now the files' names are fine and they open!
 
OP
B

beast1e

Member

Reaction score: 2
Messages: 24

But when I changed the region to that country, my settings language switched to it, so I tried US and it worked! I assume it was something with the "Default" region option. It opens and shows cyrillic characters completely fine with US...
 

rigoletto@

Daemon
Developer

Reaction score: 1,207
Messages: 2,250

Depending on your situation and needs you may want to have a look on your LOCALE configurations (aka region), and do a fine tuning. I for example use something mixed:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_COLLATE=C
LC_TIME="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_MONETARY=pt_BR.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_ALL=

IDK what is the situation on KDE (assuming you are using it) but this is advisable to avoid setting LC_ALL, for instance.
 
Top