Solved Custom Kernel Build Fails

I got the 12.1 source code from the base/releng directory of the SVN repository which would give me the latest 12.1-RELEASE kernel (p10).
I used the GENERIC configuration to create the attached configuration file and then ran
make -j4 buildkernel KERNCONF=SMALLER
And the build goes well until kernel.full was being built. The errors from make are in the attached file.

The handbook in 8.6 states if make fails there is an error in the configuration file that is not severe enough for make to catch it. I checked it multiple times and it checks out to me as I only removed lines from the original GENERIC configuration.


  • conf.txt
    10.4 KB · Views: 129
  • make.errors.txt
    1.6 KB · Views: 138


Staff member
Few things you can try, start with building the GENERIC kernel. Make sure that builds correctly. This is not required to build a custom kernel but is a test to make sure your setup is correct. Next thing to try is without the -j. Another weird thing you might encounter is running out of memory. You'll get some weird unpredictable errors too. My solution to that is to do a reboot and start the build right after.
I built GENERIC perfectly! I also remembered the errors started at VESA, so I added syscons back. That fixed it and SMALLER built successfully.