cups Dependency, /usr/ports/print/cups-pstoraster fails.

While trying to install cups, the dependency, print/cups-pstoraster failed with the following complaint:

In file included from ./src/sjbig2.h:26:
/usr/local/include/jbig2.h:39:10: fatal error: 'memento.h' file not found
#include "memento.h"
1 error generated.
src/int.mak:1307: recipe for target 'obj/zfjbig2.o' failed
gmake[2]: *** [obj/zfjbig2.o] Error 1
gmake[2]: Leaving directory '/usr/ports/print/cups-pstoraster/work/espgs-8.15.4'
*** Error code 1
make[1]: stopped in /usr/ports/print/cups-pstoraster
*** Error code 1

. . .so where is it. It's apparently a header file . . .so what creates it?
Last edited by a moderator:
Tried both your suggestions and got the same error, while installing /print/hplip-plugin. I dug around and found simuliar reports of this error, including this thread. I cleared-recursive my config and tried a third time with the same error. My solution was to pkg install cups-pstoraster and returned to /print/hplip-plugin and the installation succeeded.

I hope this helps.