ZFS Could not determine size

Hello All,

I'm very new at all of this, please don't beat me up that much.

I did an upgrade for the 9.10 stable, after the upgrade I got the message in the subject. Restarting didn't work, shutting down didn't work, shutting down and physically disconnecting/reconnecting didn't work. Finally, I physically disconnected the drive, deleted the share and data-set (I did do select the option to delete data). So, I tried as the manual stated on importing a drive and volume. That was a couple days ago, at first I selected the import drive and it gave me the progress status bar for a whole 24 hours, is this normal for it take forever, the drive works and is healthy, I can see the drive. Since, I'm new I hadn't got around to creating a back up (I know).

1. How to import drive without erasing the data that is currently on it?
2. If I can't, how do I retrieve the data from the data from drive?
3. What information do all need to better assist me?

Thanks in advance, I admit I'm no expert but am willing to learn!!!
It sounds like you might not be using ZFS commands directly, but some type of wrapper UI. Maybe it is FreeNAS or something similar? If you could tell precisely which system you are using, exactly which commands were given (and how, like through a GUI), it could help.
I do apologize, 90% of the time I am using the GUI, so in this case, everything that I noticed and have tried to do has been in the GUI.
Maybe, I'm reading something wrong then?

We only support FreeBSD. And FreeBSD doesn't have a version 9.10.