connectiong wifi

nengkya

New Member


Messages: 1

[Ask]

I'm new here to FreeBSD 11. Succed installing, and wifi-connection through installer.

# ifconfig wlan0 :
Code:
wlan0: flags=8843<UP, BROADCAST, RUNNING, SIMPLEX, MULTICAST> metric 0 mtu 1500
ether ec:08:6b:2a:49:9c
inet6 fe80::ee08:6bff:fe2a:499c%wlan0 prefixlen 64 scopied 0x3
inet 192.168.0.11 netmask 0xffffff00 broadcast 192.168.0.255
nd6 options=23<PERFORMNUD, ACCEPT_RTADV, AUTO_LINKLOCAL> media: IEEE 802.11 Wireless Ethernet MCS mode 11ng
status: associated
ssid flashzone-seamless channell 11 (2462 MHz 11g ht/40-) bssid 14:60:80
# vi /etc/rc.conf :
Code:
clear_tmp_enable="YES"
syslogd_flags="-ss"
sendmail_enable="NONE"
hostname="FreeBSD11"
wlan ath0="wlan0"
ifconfig_wlan0="WPA DHCP"
ifconfig_wlan0_ipv6="inet6 accept_rtadv"
create_args_wlan0="country ID regdomain APAC"
local_unbound_enable="YES"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
dumpdev="AUTO"
ifconfig_wlan0="inet 192.168.0.11 netmask 255.255.255.0"
default router="192.168.0.1"
# ping 192.168.0.11 = success.

Code:
# ping 192.168.0.1
ping: sendto: Host is down
 

Phishfry

Son of Beastie

Reaction score: 1,338
Messages: 3,975

With your rc.conf you are issuing this:
ifconfig_wlan0 with an IP while also using ifconfig_wlan0=WPA DHCP setting.
That is incorrect. One setting or the other, Static IP or DHCP.

Here is mine on DHCP
wlans_ath0="wlan0"
ifconfig_wlan0="WPA DHCP"


Drop these lines on your rc.conf for DHCP client mode:
ifconfig_wlan0="inet 192.168.0.11 netmask 255.255.255.0"
default router="192.168.0.1"


I am pretty sure you don't need these either:
local_unbound_enable="YES"
Personally I would drop IPv6 too until you get it working:
ifconfig_wlan0_ipv6="inet6 accept_rtadv"
 
Top