compiz-fusion gnome already has a window manager

ter2007

Member

Reaction score: 2
Messages: 75

I never have had any trouble running compiz-fusion with an nvidia graphics card until now.

I have tried and tried everything I can think of and have searched the internet.

When I start compiz-fusion the CPU usage shoots up to 100%, and hangs. When I get back to the console. it is spitting out messages like: "already has a window manager" and use "--replace option to replace current window manager"

Yes, I know the various well published commands to start compiz and emerald.

This is a fresh install:

FreeBSD 7-3 with the ports from the CD. No ports are updated.

xorg

gnome2-lite

nvidia driver 173, nvidia-xconfig, nvidia-settings (downgraded these but still the same results)

compiz-fusion port.

Please help.
 

adamk

Daemon

Reaction score: 267
Messages: 1,622

Exactly what command are you running to start compiz? Do you have compositing enabled in metacity? What is the output of 'glxinfo'?

Adam
 

jalla

Well-Known Member

Reaction score: 86
Messages: 385

I've noticed the same.

In lack of a better solution I applied the following hack to work around it

Run gconf-editor, navigate to /apps/gnome/session/required_components/windowmanager and replace metacity with dummy

Open System->Preferences->Startup Applications and add a script to start compiz. Mine looks like this
Code:
gong:~% cat /h/tl/bin/startcf.sh 
#!/bin/sh
compiz --replace --sm-disable --ignore-desktop-hints ccp &
emerald --replace &
 

jnr

Member

Reaction score: 12
Messages: 73

You can also use # compiz-manager in Startup applications instead of writing a script. It will start emerald automatically if you have emerald set as the default wm in CompizConfig.
 
OP
T

ter2007

Member

Reaction score: 2
Messages: 75

(1) For glxinfo i get: command not found. The mesa-apps is not in the ports.
(2) I could not find composting in Metacity. Don't know where it is. I am not an expert in FreeBSD (it take a long time to learn all of this and I don't have time anyway.
(3) I could not find a setting for a wm in CompizConfig. I have seen it before, but I could not remember where it is.
(4) I used jalla' method and it is working now. In fact that is the way that I have always started compiz-fusion except for the 'dummy' setting. BTW it is not / apps/gnome/session/required_components/windowmanager it is desktop/gnome/session/required_components/windowmanager to set dummy. Thanks jalla.
 
Top