Solved Chromium won't start in Xfce

I somehow managed to install Xfce and now am sloshing through Chapter 6 of the Handbook.
First I installed Chromium and it didn't report any errors. Yet it didn't appear in the list of browsers when I clicked the Web Browser button at the bottom of the screen. And when I chose it explicitly - /usr/local/bin/chrome - it reported an error. Now it reports the same error every time I click that button:

Failed to execute default Web Browser.
Input/output error.

Would appreciate it if someone would help me out of this trouble.

-
 

SirDice

Administrator
Staff member
Administrator
Moderator
Yeah, forget about running Chromium or any of the other big browsers. Just not enough memory. It needs to cram the OS and Xorg into that 1.5 GB too.
 
Yeah, forget about running Chromium or any of the other big browsers. Just not enough memory. It needs to cram the OS and Xorg into that 1.5 GB too.

It used to run Windows Vista with Google Chrome, an older version - 49.0.2623.112
Actually, it still runs them albeit without support.

That was the idea - to run a not-so-voracious system on a good old notebook. A new notebook will come with Windows - why would I want FreeBSD?

Ok. Thank you.

-
 

SirDice

Administrator
Staff member
Administrator
Moderator
At the moment you're trying to shoehorn a 500 pound gorilla in a tiny cage. Either get a bigger cage or a smaller monkey.
 
As a package:

pkg install chromium

I didn't know it could start from terminal. It reports an error:

Text segment size exceeds system limit
Abort

Doesn't look very inspiriting, does it?

-

Seems like you're hitting virtual memory limits, not physical memory.

Are you running 32 bits FreeBSD?

Maybe you can bump kern.maxtsiz (in /boot/loader.conf). It talks about it a bit in tuning(7). I think it's 128M by default on i386 (not sure, it could be auto-tuned...). But I'd try setting it to 256M.

It might make chromium work but it's probably going to swap a lot...
 
kern.maxtsiz (in /boot/loader.conf)

Ok. I opened /boot/loader.conf in ee and it was empty. So I added this line:

kern.maxtsiz=268435456

After restarting the system Chromium failed with the same error and when I checked loader.conf, my redaction was reversed - it was empty again.

On the Net I learned that there is another file to try to tweak kernel settings - /ets/sysctl.conf.

I added the above line to it and this time the system didn't dump my addition. Yet Chromium failed with a different error:

Missing X server or $DISPLAY

I thought I had botched my Xfce installation but it started and in it Chromium started and here I am posting this message from FreeBSD.

My heartfelt thanks to Mathieu.

The prospect looks cheerful again so expect me with more problems.

-
 
Ok. I opened /boot/loader.conf in ee and it was empty. So I added this line:

kern.maxtsiz=268435456

After restarting the system Chromium failed with the same error and when I checked loader.conf, my redaction was reversed - it was empty again.

Strange...

On the Net I learned that there is another file to try to tweak kernel settings - /ets/sysctl.conf.

I added the above line to it and this time the system didn't dump my addition. Yet Chromium failed with a different error:

Missing X server or $DISPLAY

Did you run the command from tmux/screen or something? Or an ssh session, or system virtual terminals?

Processes started from the X session will inherit a $DISPLAY variable pointing to the X server. But if the process was started from outside the session it might not have the variable. You can check if it's set for a certain shell with `echo $DISPLAY`. Usually the X server is the first (and only) one on the computer so you can set the variable with `export DISPLAY=:0` and then running X programs should work from that shell.

But it's probably better to run X programs from a shell that properly inherited everything from the X session, there are other variables that may or may not be important for some things.

I thought I had botched my Xfce installation but it started and in it Chromium started and here I am posting this message from FreeBSD.

My heartfelt thanks to Mathieu.

The prospect looks cheerful again so expect me with more problems.

-

Alright, you're welcome!
 
Did you run the command from tmux/screen or something? Or an ssh session, or system virtual terminals?

It's ttyv0 - the first thing I see before logging in. My shell is set to /bin/csh. If $DISPLAY is an environment variable, than it is not there:

echo $DISPLAY
DISPLAY: Undefined Variable.

export DISPLAY=:0
export: Command not found

setenv DISPLAY :0
echo $DISPLAY
:0
chrome
Missing X server or $DISPLAY
The platform failed to initialize. Exiting.

-
 
It's ttyv0 - the first thing I see before logging in. My shell is set to /bin/csh. If $DISPLAY is an environment variable, than it is not there:

echo $DISPLAY
DISPLAY: Undefined Variable.

export DISPLAY=:0
export: Command not found

setenv DISPLAY :0
echo $DISPLAY
:0
chrome
Missing X server or $DISPLAY
The platform failed to initialize. Exiting.

-

Are you typing that at ttyv0 before the X server is running? If so then that's why it wouldn't work. If not then I just don't get it.

To try to run chrome as a command (to see its startup error messages), best way is to do it is from a terminal program "within" the X session (and then it'll have the needed environment variables). Like with XFCE's one it calls just "Terminal Emulator". Or "xterm", etc.
 
Top