Solved Chromium pulseaudio enable but no sound.

Hello everybody,

i installed freebsd 13 with xfce and the xfce pulseaudio plugin as a mixer for audio management.
I have Firefox installed and the audio works perfectly.
I wanted to try chromium and so I installed it but, although I have enabled pulseaudio with 'make config' when I try to test everything with a video on youtube I don't hear anything and even in the mixer the chromium application does not appear contrary to what happens with firefox.
I have certainly done something wrong.

Thank you all.


Well, there's not really information in your post that could help to point to the actual problem. But then, my first impulse would be: keep it simple.

Is there a specific reason for using pulseaudio? I know audio on Linux is more or less a mess and pulseaudio is the solution to a problem that shouldn't exist in the first place … on FreeBSD, the "OSS interface" is working just fine and, in my experience, flawless. Chromium doesn't seem to have a classic OSS backend – I use sndio here instead (see audio/sndio), which is a simple and quite minimal approach to a "sound daemon", MUCH simpler than pulseaudio, and this is working fine…
Hi Zirias,

being a novice i am probably getting confused.
After the installation with xfce working I downloaded the pulse audio mixer because with Firefox I did not hear anything and I did not see any audio management icon and thanks to this graphic mixer I was able to make the audio work.
I guess he also installed the pulse audio "daemon" for me which relies on the integrated realtek audio chipset driver.
I will be happy to use sndio but does it have a graphic mixer for management?
Finally excuse the beginner question: is there no audio daemon loaded by default?

Thanks and sorry for my English.


First off, there's no need for an audio daemon. FreeBSD's OSS implementation can mix multiple clients without any additional software involved. Still it uses the classic OSS interface (consisting of devices like /dev/dsp and /dev/mixer). This also means you can use any mixer app you like as long as it supports the OSS /dev/mixer. I don't use any GUI tools for that, so can't give you any recommendations.

Second, I picked sndio just because it's really simple in design (which often correlates to fewer problems), just for these applications that don't have an OSS backend. OTOH, an ALSA backend would work as well. Although ALSA has its own driver model (this thing Linux introduced after being unable to solve some problems with OSS that FreeBSD could solve, hehe), it can operate on top of OSS, which is what the FreeBSD port of it will do. Yet another option would be SDL, which works well on top of OSS as well.
On Linux, but not FreeBSD, with many distributions, pulseaudio is necessary for sound to work in Firefox, or as I say, in my more "Get off my lawn" moods, in Firefox's never ending effort to drive people to use Chrome.

However, in FreeBSD, pulse is *NOT* needed. (As Zirias has already stated,) My only addtion to his comments is that I've installed both firefox and chromium using pkg, with no worries about configuring sound and it just worked. I use openbox, fluxbox, and dwm, rather than a desktop environment like Xfce, but I don't see that making a difference.
Usually I dislike Linux bashing, but Zirias is spot on with this. Linux continues to create solutions in search of problems with audio, making problems.

Deleted member 30996

But then, my first impulse would be: keep it simple.
That would be my advise.

I've got www/firefox-esr, multimedia/audacious and multimedia/audacious-plugins built from ports on all my machines. When I compile ports I go with the default settings.

I have several screenshots with top showing pulseaudio at work while listening to Audacious and get sound through Firefox when listening to youtube videos without doing anything special to set up sound:

Thanks to everyone for the information, I will try to get as much practice with the system as possible.
Hello everybody,
following your instructions and reading the handbook now the audio works perfectly with both Chromium and Firefox.

Thank you
As the thread originator, you can mark the thread as solved. Go to the original post, click edit, and you should see a place to put a prefix. One of the choices is solved.

Glad you were able to fix it. Do you know what changes you made to get it to work? (That might help someone who comes upon this thread in the future.)