Solved Changing screen resolution

I've done a lot of reading but I'm still confused. My screen resolution is set at 1024 x 768 and that's too big for my laptops screen. As a linux user my first thought was to simply change it in xorg.conf. From what I've read it appears that it has to be generated. After doing a lot of googling I came up with a number of things but I don't know how to interpret them.

# vidcontrol -i mode
vidcontrol: getting active vty: Inappropriate ioctl for device

From dmesg
VT(vga): resolution 640x480

module_register_init: MOD_LOAD (vesa, 0xffffffff8101c950, 0) error 19
vtvga0: <VT VGA driver> on motherboard
vgapci0: <VGA-compatible display> port 0x5000-0x503f mem 0xf0000000-0xf03fffff,0xe0000000-0xefffffff irq 16 at device 2.0 on pci0
vgapci0: Boot video device

I'm not sure what all is relevant so I'm guessing. This isn't a major issue but with this screen resolution I have to scroll sideways. I appreciate your patience.

As a linux user my first thought was to simply change it in xorg.conf.
xorg is xorg, how is it related to FreeBSD?
Nowadays in many setups you don't even need xorg.conf.

vidcontrol: getting active vty: Inappropriate ioctl for device
vidcontrol(1) is for console, not xorg.

What's your graphic card?
E.g., if it's Intel and it's supported by FreeBSD (see this page), you will need to add to your /boot/loader:
It doesn't appear that there is much intel support. Yet when I bought this laptop it was on the approved list of laptops that are 100% compatible.

Any way here's what I get
vgapci0@pci0:0:2:0:    class=0x030000 card=0x21da17aa chip=0x01268086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '2nd Generation Core Processor Family Integrated Graphics Controller'
    class      = display
    subclass   = VGA

I checked that against the approved list and don't see anything like it.
Please post your /var/log/Xorg.0.log to Pastebin or a similar service.
[ 132.823] (WW) Warning, couldn't open module intel
[ 132.823] (II) UnloadModule: "intel"
[ 132.823] (II) Unloading intel
[ 132.823] (EE) Failed to load module "intel" (module does not exist, 0)
[ 132.823] (II) LoadModule: "modesetting"
[ 132.824] (II) Loading /usr/local/lib/xorg/modules/drivers/
[ 132.825] (II) Module modesetting: vendor="X.Org Foundation"
This is suspicious. Is x11-drivers/xf86-video-intel installed? In theory it should work with modesetting too, but that would require preloading i915kms like aragats suggested above.

I checked that against the approved list and don't see anything like it.
You have a Sandy Bridge GPU so it should be supported.
The driver isn't installed so I followed the instructions and got the following. I don't know why I run into so many problems but the port won't build.

Package dri3proto was not found in the pkg-config search path.
Perhaps you should add the directory containing `dri3proto.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dri3proto', required by 'xorg-server', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to [maintainer] and attach the
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1
That is way over my head.

So I messed with xrandr

root@localhost:# xrandr
No protocol specified
Can't open display :0
root@localhost:#cvt 800 600
# 800x600 59.86 Hz (CVT 0.48M3) hsync: 37.35 kHz; pclk: 38.25 MHz
Modeline "800x600_60.00"   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync]/code]

Which if I'm interpreting it correctly then that resolution is available,  I don't need to add anything.  And that's as far as I've gotten.  Please talk to me as if I know nothing because at this point that's how I feel.  Thanks

Edit I think I'm making progress so I'll post back later
Problem solved! I did a lot of googling and reading and more googling and reading. Since I couldn't get that port to install I used portsnap, installed the driver, went into system settings and changed my resolution. It turned out I needed a higher resolution. Thanks for pointing me in the right direction. Now I don't feel like an idiot! :D