Solved Changing Display Device Without Xorg

D

Deleted member 62636

Guest


Hello, I have installed an AMD GPU to my system in order to use GPU accelerated OpenCL (Not OpenGL). My system uses onboard Intel graphics with syscons(4) for console display (I didn't install X) But after the GPU installation server only outputs through the GPU's VGA port rather than motherboard's. I want to use my onboard graphics for display and don't want to output anything to the GPU (It's only going to be used for OpenCL).
How can I do that?

The Solution was to both load KMS drivers, and enable IGD.
 

olli@

Daemon
Developer

Reaction score: 1,230
Messages: 1,120

There should be a setting in the BIOS setup like “prefer onboard VGA” or “display priority” or something similar. syscons(4) only picks up what the BIOS uses, so this must be configured with your BIOS, not with FreeBSD.
 
OP
D

Deleted member 62636

Guest


There should be a setting in the BIOS setup like “prefer onboard VGA” or “display priority” or something similar. syscons(4) only picks up what the BIOS uses, so this must be configured with your BIOS, not with FreeBSD.
I just checked and there isn't any. Now what?
 

Argentum

Well-Known Member

Reaction score: 195
Messages: 424

I just checked and there isn't any. Now what?
Do you have DRM loaded? The discrete card is AMDGPU, but what is the built in GPU? You can try to load DRM for that. It may recognize your on-board GPU even when it is switched off by BIOS.

For example, if it is intel, put kld_list="/boot/modules/i915kms.ko" in the /etc/rc.conf. If this is legacy Radeon, put kld_list="/boot/modules/radeonkms.ko" in. This should not interfere with AMDGPU and may, with good luck, recognize you on-board GPU.
 
OP
D

Deleted member 62636

Guest


Do you have DRM loaded? The discrete card is AMDGPU, but what is the built in GPU? You can try to load DRM for that. It may recognize your on-board GPU even when it is switched off by BIOS.

For example, if it is intel, put kld_list="/boot/modules/i915kms.ko" in the /etc/rc.conf. If this is legacy Radeon, put [icde]kld_list="/boot/modules/radeonkms.ko"[/icode] in. This should not interfere with AMDGPU and may, with good luck, recognize you on-board GPU.
Mine onboard graphics is Intel, I tried putting kld_list="/boot/modules/i915kms.ko" but It didn't work.
 
OP
D

Deleted member 62636

Guest


No I don't have that installed, do I need it?
 

olli@

Daemon
Developer

Reaction score: 1,230
Messages: 1,120

I just checked and there isn't any. Now what?
Now that’s bad luck. In that case the display selection logic is probably hardcoded in your BIOS.

As I mentioned before, syscons(4) will pick up whatever the BIOS uses for its output. Loading any of the DRM / KMS modules won’t change that. (Assuming that you don’t want to install Xorg.)
 
OP
D

Deleted member 62636

Guest


Now that’s bad luck. In that case the display selection logic is probably hardcoded in your BIOS.

As I mentioned before, syscons(4) will pick up whatever the BIOS uses for its output. Loading any of the DRM / KMS modules won’t change that. (Assuming that you don’t want to install Xorg.)
So I can't do anything about it?
Edit: I changed to vt(4) maybe that will help?
 

6502

Member

Reaction score: 30
Messages: 99

I want to use my onboard graphics for display and don't want to output anything to the GPU (It's only going to be used for OpenCL).
How can I do that?
Do you see anything on display at startup (before OS is loaded)? And why you simply do not remove the graphic card?
 

olli@

Daemon
Developer

Reaction score: 1,230
Messages: 1,120

So I can't do anything about it?
I’m afraid you can’t. Unless you’re willing to run Xorg, of course.

By the way, syscons(4) is considered “legacy”. I recommend to use the new default console driver vt(4), unless you have a specific reason to keep using syscons. It shouldn’t make a difference for this particular problem, though.
 

olli@

Daemon
Developer

Reaction score: 1,230
Messages: 1,120

Edit: I changed to vt(4) maybe that will help?

Actually I’m not sure.

I think vt(4) also picks up the display from the BIOS (or UEFI). However, if I remember correctly, vt(4) at least has some tunables to switch the output connector (e.g. if your graphics hardware has a HDMI connector and a DisplayPort connector), so there might be a way to switch the graphics hardware, too. But I’m really not sure.

You might try loading the KMS module for your onboard graphics (intel), do not[ load the AMD module. Then watch the boot messages to see if it is recognized. It should list the graphics hardware and the connectors. Please refer to the vt(4) manual page, in particular the section “Start-up Operation with x86 BIOS Systems” and the loader tunable kern.vt.fb.modes.connector_name.
 
OP
D

Deleted member 62636

Guest


Then watch the boot messages to see if it is recognized.
First this one: vtvga0: <VT VGA driver> on motherboard

and this one: vgapci0: boot video device
 

shkhln

Daemon

Reaction score: 917
Messages: 2,140

Check it again.
I'm not being facetious. Google tells me you have an ECS H81H3-M4 motherboard, the setting is called "Initiate Graphic Adapter" and should be somewhere in the chipset settings section.
 
OP
D

Deleted member 62636

Guest


I'm not being facetious. Google tells me you have an ECS H81H3-M4 motherboard, the setting is called "Initiate Graphic Adapter" and should be somewhere in the chipset settings section.
Out of curiosity, how did you know my motherboard? I don't remember sharing it anywhere.
 
OP
D

Deleted member 62636

Guest


I'm not being facetious. Google tells me you have an ECS H81H3-M4 motherboard, the setting is called "Initiate Graphic Adapter" and should be somewhere in the chipset settings section.
Only "System Agent Configuration"
"PCH configuration"
and
"ME Configuration"
 

shkhln

Daemon

Reaction score: 917
Messages: 2,140

Only "System Agent Configuration"
"PCH configuration"
and
"ME Configuration"
See if you aren't in some kind of "dummy" mode, where most options are hidden. Click on everything labeled "advanced" and so on.
 
OP
D

Deleted member 62636

Guest


See if you aren't in some kind of "dummy" mode, where most options are hidden. Click on everything labeled "advanced" and so on.
Yep, I am on advanced settings.
 
Top