Solved Change storage driver during install

Tomse

Member

Reaction score: 2
Messages: 41

I'm still fighting getting those Dell 730 and 630 servers to work with FreeBSD.

I'm fighting with problems such as when starting a program like ssh(1), make(1) or screen(4) I get
Code:
Illegal instructions (Core Dumped)


Code:
mfid timeouts (controller)


Code:
NMI errors (this happens on one server during install)


I've been digging some and found that the mfi(4) driver is an old driver and I should be using mrsas(4) instead.

The controller in use is the PERC 730 which is an internal one.

How can I change the installer to use this driver instead? (as I said, I can't even install FreeBSD one one of the servers).

Though it's Dell (I'm starting to hate the company) I'm hesitant to blame the hardware on 4 servers (out of 5 tried).
 
OP
Tomse

Tomse

Member

Reaction score: 2
Messages: 41

No one knows how to change storage drivers during install ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,383
Messages: 33,987

When the installer boots and you see the menu, choose to drop to the loader prompt. Then enter:
Code:
set hw.mfi.mrsas_enable="1"
boot

That should force the detection of mrsas(4) instead of mfi(4).
 
OP
Tomse

Tomse

Member

Reaction score: 2
Messages: 41

I finally found time to test this setting, and now it works with UEFI boot.

(the following is for reference if other people are having the same issue)
of course I had to enter the setting again upon first boot, then add

Code:
set hw.mfi.mrsas_enable="1"

to /boot/loader.conf to make the change permanent.

Unfortunately I can't add an extra "Thank you" to you [USER=1677]SirDice[/USER], but I hope you appreciate the thought of the extra thanks :)
 

Tim L

New Member

Reaction score: 1
Messages: 4

I had the same issue with a PowerEdge T330 and FreeBSD 10.3. The process above did the trick. Thanks for posting the solution. One note though for the next person. You need to add
Code:
hw.mfi.mrsas_enable=1

without "set" to /boot/loader.conf
 
Top