Solved Change language TTYv to spanish (UTF-8)

Spity

New Member

Reaction score: 2
Messages: 16

How can I change the keyboard of the virtual terminals? The one that comes by default is "us" and I would like to put it in Spanish (es). kdbmap allows me to do it but the change is not permanent after reboot.
 

xavi

Active Member

Reaction score: 110
Messages: 164

How can I change the keyboard of the virtual terminals? The one that comes by default is "us" and I would like to put it in Spanish (es). kdbmap allows me to do it but the change is not permanent after reboot.
You can check out this thread. Please let us know if it works for you.
 
OP
Spity

Spity

New Member

Reaction score: 2
Messages: 16

I got it. In gnome all works fine. But in the TTY in each reboot I have the keyboard in English language. When I run kbdmap I can change it to Spanish, but every reboot it goes back to English (us) and I have to run kbdmap again.
 

xavi

Active Member

Reaction score: 110
Messages: 164

I have: keymap="es.acc.kbd"
Have you tried the instructions in this post? That uses "es" instead of "es.acc.kbd". You might also want to make the change to /etc/login.conf and then run cap_mkdb /etc/login.conf. Running locale -a will show you what your current locales are.
 
OP
Spity

Spity

New Member

Reaction score: 2
Messages: 16

ok, if I create a folder called "ñoqui" in gnome and see it from tty I get this:? oqui. I think it has to do with gnome is in utf-8 and my kern.vty = sc is in iso-8859-1 and I can't change it to utf.
 

judd

Active Member

Reaction score: 159
Messages: 206

[USER=65535]Spity[/USER]
Add the following to the .login_conf file:

Code:
me:\
        :charset=UTF-8:\
        :lang=es_ES.UTF-8:\
        :setenv=LC_COLLATE=C:


restart
 

xavi

Active Member

Reaction score: 110
Messages: 164

I'm not sure that a restart will be enough. According to the man page for login.conf the following advice applies:

The default /etc/login.conf shipped with FreeBSD is an out of the box configuration. Whenever changes to this, or the user's ~/.login_conf, file are made, the modifications will not be picked up until cap_mkdb(1) is used to compile the file into a database.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,783
Messages: 34,911

No need to restart either, just log off and back in again. The settings are applied at login.
 
OP
Spity

Spity

New Member

Reaction score: 2
Messages: 16

Solved. Testing and following these steps:
The only thing I had to modify was the console kern.vty=sc by hw.vga.textmode=1

The .login_conf in home, was not modified. only /etc/login.conf

* I miss the colors of the kern.vty=sc at startup, but at least I have letters in Spanish *
 

Snurg

Aspiring Daemon

Reaction score: 343
Messages: 823

* I miss the colors of the kern.vty=sc at startup, but at least I have letters in Spanish *
For setting other colors in sc, you need to build a kernel :(
Here are my sc settings:
Code:
# syscons is the default console driver, resembling an SCO console
device          sc
#options SC_PIXEL_MODE # add support for the raster text mode
options SC_HISTORY_SIZE=500
options SC_NORM_ATTR=(FG_BLACK|BG_GREEN)
options SC_NORM_REV_ATTR=(FG_BLACK|BG_CYAN)
options SC_KERNEL_CONS_ATTR=(FG_BLACK|BG_RED)
options SC_KERNEL_CONS_REV_ATTR=(FG_BLACK|BG_BROWN)


Note that there is no need to include the VESA driver when using sc, and in fact it is detrimental, as suspend/resume fails when it is included. So you might want to disable that also:
Code:
#options        VESA                    # Add support for VESA BIOS Extensions (VBE)
 
Top