Solved Change language of Gnome Desktop

Spity

Member

Reaction score: 5
Messages: 48

Hi, I have installed FreeBSD 12.2 with Gnome. Is there any way to change it to Spanish?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,724
Messages: 39,312

No. I have changed it from gnome settings, etc. Restart and nothing. still in english.
Are other Gnome settings applied? And which part are you talking about? The system's language or the Gnome desktop? These are different and one has no influence on the other.

 

fjdlr

Member

Reaction score: 46
Messages: 59

Maybe the sampled here https://forums.freebsd.org/threads/slim-xorg-fr.58380/, and changed for Spanish language
my /usr/local/etc/X11/xorg.conf.d/10-keyboard.conf:
Code:
Section "InputClass"
        Identifier "Keyboard0"
        MatchIsKeyboard "on"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"
        Option "xkb_rules" "evdev"
    Option "XkbVariant" "oss"
    Option "XkbOptions" "terminate:ctrl_alt_bksp,ctrl:nocaps"
EndSection
 
OP
Spity

Spity

Member

Reaction score: 5
Messages: 48

Solved, editing:
/usr/local/etc/gdm/locale.conf

LANG="es_AR.UTF-8"
LC_CTYPE="es_AR.UTF-8"
LC_MESSAGES="es_AR.UTF-8"

and gnome is in spanish.
 
Top