• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Centos 6 (vm-bhyve) not start while restart

TINC

New Member

Thanks: 1
Messages: 16

#1
While restart, VM based on CentOS 6.8 not start (but first start - no problems). I migrated it from other server, there were no problems.

Log:
Code:
Jan 17 17:19:17: restarting
Jan 17 17:19:17: create file /vm/san/device.map
Jan 17 17:19:17:  -> (hd0) /vm/san/san_centos.img
Jan 17 17:19:17: create file /vm/san/grub.cfg
Jan 17 17:19:17:  -> timeout=3
Jan 17 17:19:17:  -> menuentry 'san (bhyve run)' {
Jan 17 17:19:17:  ->     root=hd0,1
Jan 17 17:19:17:  ->     linux /vmlinuz-2.6.32-642.11.1.el6.x86_64 root=/dev/mapper/VolGroup-lv_root
Jan 17 17:19:17:  ->     initrd /initramfs-2.6.32-642.11.1.el6.x86_64.img
Jan 17 17:19:17:  -> }
Jan 17 17:19:17: /usr/local/sbin/grub-bhyve -c /dev/nmdm0A -S -m /vm/san/device.map -M 8G -r host -d /vm/san san
Jan 17 17:19:17: fatal; loader returned error 1
Jan 17 17:19:17: destroying network device tap0
Jan 17 17:19:17: stopped
Config:
Code:
# cat san.conf
guest="linux"
loader="grub"
cpu=4
memory=8G
passthru0="1/0/0"
passthru1="1/0/1"
disk0_type="virtio-blk"
disk0_name="san_centos.img"
network0_type="virtio-net"
network0_switch="vipnet"
network0_mac="58:9c:fc:03:b9:cb"
grub_run0="linux /vmlinuz-2.6.32-642.11.1.el6.x86_64 root=/dev/mapper/VolGroup-lv_root"
grub_run1="initrd /initramfs-2.6.32-642.11.1.el6.x86_64.img"
uuid="f41ccc8f-2c9b-11e6-a8a6-288023a946e0"