• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Catch 22 probIem cannot use su but need to be root to enable su

sedge

New Member

Thanks: 3
Messages: 14

#1
I am a new FreeBSD user and some how I have been removed from the wheel and operator groups.
$ su returns "sorry'
Running "$ pw usermode ken -G wheel" returns "you need to be root" but I cannot become root until I add myself to wheel group!
Logged in to single user but the file system is mounted "read only".
An internet search gave "/rescue/mount -rw /" to make it read and write but this tells me "/' is unknown.
I have ZFS file system and KDE desktop
Any help appreciated.
KEN
 

chrbr

Aspiring Daemon

Thanks: 225
Messages: 627

#2
An internet search gave "/rescue/mount -rw /" to make it read and write but this tells me "/' is unknown.
I have ZFS file system
With zfs it is slightly different. zfs set readonly=off THE_POOL makes the pool THE_POOL writable. To mount everything zfs mount -a should be ok. Then you can modify passwords and goups. It is best to use vipw(8) for /etc/passwd and vigr(8) for /etc/group because additional steps are run automatically.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,098
Messages: 26,991

#3
Just login on the console as root. Then add your user to the wheel group. There's really no need to do this in single user mode.
 

sedge

New Member

Thanks: 3
Messages: 14

#6
Thanks for all the replies
chrbr thanks your reply set me on the right direction , running zfs set readonly=off THE_POOL told me it did not like THE_POOL.
I tried zfs set readonly=off zroot this worked,. I could not figure out how vigr worked so I edited the file with ee.
 

chrbr

Aspiring Daemon

Thanks: 225
Messages: 627

#7
zfs set readonly=off THE_POOL
Sorry, I meant THE_POOL as a placeholder for the name of the pool o_O. Regarding vipw(8) and vigr(8) the commands are similar to vi(1). On the first look this editor is slightly unusual, but it is very powerful and always available. Therefore it pays back if you learn how to edit a file using this edtior.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,098
Messages: 26,991

#8
This isn't even needed. Just boot the machine normally and login as root on the console. There's absolutely no reason to do this in single user mode.

Once logged in as root: pw groupmod -m ken wheel.
 

sedge

New Member

Thanks: 3
Messages: 14

#9
I am a new to Freebsd and need all the help and advice I can get!
I always appreciate people taking the time and trouble to answer my questions.
With respect to "login as root on the console' I have not worked out how to do that yet.
I have a couple of Unix books and Linux Command instant reference book that help.
The Freebsd Handbook appears to be out of date especially with regard to setting up xorg, it took quite a while to figure out how to set it up to use the Nvidia driver.
Experience is something you don't get until just after you need it. I have to agree also no question is silly if you do not know the answer
Anyway thank you all for taking the time to answer my post.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,098
Messages: 26,991

#10
With respect to "login as root on the console' I have not worked out how to do that yet.
Go sit behind the computer, boot it. Wait until the "login" prompt appears, login as root.
 

ShelLuser

Son of Beastie

Thanks: 1,266
Messages: 2,694

#11
Other than what SirDice said: If for some reason your setup boots into a GUI (a login manager for example) then you can press control-alt-f1 to switch back to the regular console. Normally this always works, however, I am aware of situations where the console can get messed up a bit where graphics is concerned as long as you have X (the GUI) running. That's usually a driver issue. If this applies then simply quit X and things should reset to normal.

Hope this can help too.
 

chrbr

Aspiring Daemon

Thanks: 225
Messages: 627

#12
With respect to "login as root on the console' I have not worked out how to do that yet.
Dear sedge, may be you come fro the Ubuntu world? As far as I remember here is no root password by default. FreeBSD is different. At the time of the FreeBSD installation giving a root password has been requested. In contrast to Ubuntu or other Linux distributions it is normal to login as root if necessary. And of course normal things should be done using a normal user account. If you have the root password the login is not different from a user login.
 

sedge

New Member

Thanks: 3
Messages: 14

#13
I have been using linux for about 20 year. My ebay account was hacked into recently so I thought I would try something new.
I followed the instructions in the handbook for installation and setting up my system, it boots straight into the KDE log in screen.
The control-alt-f1 command is something I will have to experiment with.
And at 73 years old every bit of info is always welcome.
 

chrbr

Aspiring Daemon

Thanks: 225
Messages: 627

#14
I have been using linux for about 20 year.
Then you will have no problems with FreeBSD because many things are similar from the user perspective. As far as I remember it has been normal under Linux to start with the console and switch to X11 by startx.
it boots straight into the KDE log in screen
I prefer not to start the GUI immeditately, but this is a matter of taste.
And at 73 years old every bit of info is always welcome.
In my opinion it is a perfect training for the brain to start with something new! There are too many people which are much younger than you but already too tired to continue learning. I hope I will be as motivated as you when I will be 73 years old, I am 20 years behind :beer::).
 

sedge

New Member

Thanks: 3
Messages: 14

#15
I started with hobby computing in 1987(?)with an Amstrad 1640 and MS-Dos. .
Did a Computer technicians course, had a go at building my own computers, I now buy used computers to use.
I am using a HP Compaq 8000 workstation at the moment having changed the video card and fitted a 1Tb hybrid hard drive
Gave up on Micosoft with Windoze 97, and started with some of the earlier nix OS's, then started using Ubuntu from its inception.
Things have come a long way since Bill Gates said "who needs more than 640K of memory".
I am having a job to keep up with all the changes now but I do my best.
Thanks once again everybody for all your help.
We could now mark this as problem solved.
Ken
 

chrbr

Aspiring Daemon

Thanks: 225
Messages: 627

#16
We could now mark this as problem solved.
Perfect, you can do that as the original poster by the following procedure. Please click on "Thread Tools" at the top of the first post, select "Edit Title", and use the dropdown menu to select the green 'Solved' button. This is shamelessly copied from Thread 45558.
 
Top