MATE Can't shutdown or restart from within Mate Desktop

ImageJPEG

Member


Messages: 23

#1
I've posted this on the Mate forums about two weeks ago with no reply. It's still at the top of the page even.

Anyway, here's my issue:
I have no ability to shutdown or restart my computer within Mate other than the command line. The shutdown and restart buttons are literally missing from the "Shutdown" option under "System".

I've also noticed that I can't use mate-system-log anymore either. It seems to be directly tied with the power issue because when the shutdown/restart buttons were visible, I would be able to get into my system log viewer. I receive this error:

Code:
pkexec mate-system-log
Error executing command as another user: Not authorized

This incident has been reported.
A few days ago, this would seemingly happen at random. My usual way of getting around this was to log out and log back in. After doing that, I'd get my shutdown/restart buttons and I would be able to start my system log viewer. For whatever reason, today, it will not work no matter how many times I login/out, restart my DM or even restart my computer.

I've got some screenshots of what the power buttons are suppose to look like and what they look like when they're missing:

How it's suppose to look:
https://www.dropbox.com/s/gei1qkwgo4tbla2/shutdown issue.png?dl=0

How it's not suppose to look like:
https://www.dropbox.com/s/gp7n0mr2p5d1fk4/Screenshot-8 (1).png?dl=0

My current system setup is as follows:
Mate Desktop 1.8.1
FreeBSD 10.1-RELEASE-p6
Nvidia drivers 346.35 for a GT 520.

I've installed only binary packages by the way.

Here's my post on the Mate forums.
http://forums.mate-desktop.org/viewtopic.php?f=11&t=3454
 

abishai

Aspiring Daemon

Thanks: 134
Messages: 604

#2
I don't have Mate or similar problems, but reboot and shutdown are privileged operations, so session manager should be able to provide such functionality if
1) started with suid bit or
2) relies on polkit or
3) implements sudo fallback or
4) runs necessary commands under logged user

I suggest to start checking 2) or 3)

2) Polkit has configuration files here /usr/local/etc/polkit-1. You should look for *.pkla files with some obvious looking text like who can execute and what can be executed. If this files are absent, you need to provide them.
3) Unprivileged attempt of sudo call will be logged. Just check your system logs.
 

Endoril

New Member


Messages: 7

#6
Ok, it is a bit late, and a pretty weird solution but i have just solved a similar problem under mate-desktop 1.8.1_1.

My problem has begun when removing the "Software/Folders/System" menu from MATE panel. When i have re-added it, the "shutdown" button was missing from system.

The solution is to reset configuration like this (all your program configuration will be reset, so be carefull and read the edited part of this post):

Code:
#backup & "delete" configuration and reboot
mv ~/.config ~/.config.bak && reboot
After rebooting "shutdown" button will be back (this was the case for me).

-- EDIT --

Obviously, it's not required to delete all, if you want to be more "precise" you have to find the only files required (just deleting ~/.config/mate folder does not work), but they are under the ~/.config folder, or in a subdirectory of it.
Or you can apply my solution, then copy other programs configs from your backup (in ~/.config.bak folder) to ~/.config.
 

(B)(S)mart(D)mon

New Member


Messages: 5

#7
I think a better solution could be to start MATE with ck-launch option. In your ~/.xinitrc:
Code:
exec ck-launch-session dbus-launch --exit-with-session mate-session
Also, edit /usr/local/share/polkit-1/actions/org.freedesktop.consolekit.policy and make it look like this:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
 "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/PolicyKit/1.0/policyconfig.dtd">

<!--
Policy definitions for ConsoleKit
-->

<policyconfig>

  <action id="org.freedesktop.consolekit.system.stop">
    <description>Stop the system</description>
    <message>System policy prevents stopping the system</message>
    <defaults>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

  <action id="org.freedesktop.consolekit.system.stop-multiple-users">
    <description>Stop the system when multiple users are logged in</description>
    <message>System policy prevents stopping the system when other users are logged in</message>
    <defaults>
      <allow_inactive>yes</allow_inactive>
      <allow_active>auth_admin_keep</allow_active>
    </defaults>
  </action>

  <action id="org.freedesktop.consolekit.system.restart">
    <description>Restart the system</description>
    <message>System policy prevents restarting the system</message>
    <defaults>
      <allow_inactive>yes</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>

  <action id="org.freedesktop.consolekit.system.restart-multiple-users">
    <description>Restart the system when multiple users are logged in</description>
    <message>System policy prevents restarting the system when other users are logged in</message>
    <defaults>
      <allow_inactive>yes</allow_inactive>
      <allow_active>auth_admin_keep</allow_active>
    </defaults>
  </action>

</policyconfig>
 

RingZeroCoder

New Member


Messages: 1

#8
In FreeBSD, in MATE, in a terminal window (like mate-terminal) as your preferred non-root user, run:

Code:
mate-keybinding-properties
and in the "Desktop" section, check that the default keybinding for action "Shut down" is "Ctrl+Alt+Delete".

Then try it (press the 3-key combination
Code:
"Ctrl+Alt+Delete"
). When I do, I get a GUI dialog box with "Restart", "Cancel" and "Shut Down" buttons.

Let me know how this works for you.

I realize this does not address the mate-system-log issues.
 
Top