Can't See the Installation GUI on Thinkpad


New Member

Messages: 1


I'm having trouble installing FreeBSD 12.1 on my ThinkPad T430. Flashing the OS on a USB and DVD give the same result: a tiny installation window on the top of the screen (see image). Everything seems to work, but I just can't see what I'm doing. I've also tried plugging in another monitor (the ThinkPad has a VGA port) and the separate monitor didn't display anything.

freebsd - thinkpad t430.jpg

Another thing that I've tried is taking out the SSD, putting it into another computer to install FreeBSD, then putting the SSD back in the ThinkPad. I was able to install the OS onto the SSD, but when I plugged it back into the ThinkPad, it couldn't boot from the drive.

Any help would be greatly appreciated.

Thank you!



Reaction score: 1,509
Messages: 2,114

  1. This looks like a BIOS/EFI problem to me. Make shure your BIOS version is up-to-date (
  2. The SSD does not boot because the boot method you installed it for does not match the one in the BIOS of the target machine. Nowadays, there are numerous cases, and what you want is most probably UEFI+CSM.
  3. Boot in safe+verbose mode


Son of Beastie

Reaction score: 2,389
Messages: 3,277

That's really weird. I've installed on a ThinkPad T61 and on a T20 (or 22?) before, and had no problem. Thinkpads are just about the most standard-conforming machines out there.

My only suspicion is that you may have some truly strange BIOS settings. I think the T430 may have two graphics cards ... in the BIOS you might have to select one or the other.

About the "not booting from SSD": Newer Thinkpads have some BIOS settings that can prevent booting from unknown drives. Also, you might have mixed 32- and 64-bit installs when using the two computers (unlikely but possible, since today nearly everything is 64 bit).