Solved can't mount kindle paperwhite

romanaOne

Member

Thanks: 9
Messages: 77

#1
dmesg says:
Code:
ugen0.7: <Amazon Amazon Kindle> at usbus0
umass0 on uhub0
umass0: <Mass Storage> on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x4100
umass0:4:0: Attached to scbus4
da0 at umass-sim0 bus 0 scbus4 target 0 lun 0
da0: <Kindle Internal Storage 0100> Removable Direct Access SCSI-2 device
da0: 40.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
da0: quirks=0x2<NO_6_BYTE>
There is no /dev/da0 when the kindle is connected. This means it is mtp?

simple-mtpfs -l :
Code:
simple-mtpfs -l
No raw devices found.
I have installed mtpfs and fusefs-simple-mtpfs.
I'm not sure I mtpfs set up right since I've never used it: always seemed like flakey trash for mobile phones, olde mp3 players, and other devices too stupid to run sshd.

I'm using hald/KDE4 on this system and USB drives and other readers are automatically mounted. But not Kindle Paperwhite. Kobo Touch and Kindle 3 mount without errors, Kindle Basic Edition works but you have to mount it from the command line.

I tried plugging the PW1 Kindle into my other system which has autofs working, at least for most thumbdrives, and the Kindle does not mount:
Code:
kernel: WARNING: autofs_trigger_one: request for /mtp/ completed with error 5
Maybe it would be simpler to set up usbnetwork on the PW1 than sort this out....
 

xavi

Active Member

Thanks: 77
Messages: 112

#2
Hi,

I haven't tried this myself but you could try using the DSBMD FreeBSD mounting deamon.
You can install it easily using the following command:

$ pkg install dsbmd

or build it from source:

$ cd /usr/ports/sysutils/dsbmd/ && make install clean

The following link has more information:
https://forums.freebsd.org/threads/dsbmd-a-media-mounting-daemon-automounter-for-freebsd.63534/
And the Github page at https://github.com/mrclksr/DSBMD details what it supports (it includes MTP).
The author is also active on this forum as mrclksr.

Good luck!
 
OP
OP
R

romanaOne

Member

Thanks: 9
Messages: 77

#3
I tried dsbmd but it did not work either.

I tested several phones (all mtp) and three other ebook readers (mounted as mass storage /dev/da0p1) and they all worked fine both on my system using hald + kde5 and on my system using autofs.

I think there is just something funny about the Kindle Paperwhite. I can mount it in Linux, so maybe there is something simple that just needs updating, like adding the right deviceid=0xdead, vendorid=0xbeef in some little file someplace.....
 

k.jacker

Aspiring Daemon

Thanks: 290
Messages: 529

#4
You shouldn't wait for some magic to happen that will somehow automount your kindle...

Find out about the filesystem used.
Check if the device shows up dmesg, usbconfig, camcontrol devlist
Check if the filesystem shows up gpart show
and finally check if FreeBSD can mount. If not, check the ports for tools to mout it or even show up.
Automountig comes last, after you managed to mount it by hand.
 
OP
OP
R

romanaOne

Member

Thanks: 9
Messages: 77

#5
So I finally got it to mount by rebooting the kindle and just mounting it :
Code:
>mount -t msdosfs /dev/da0s1 /mnt
It isn't using MTP. (That wild goose chase got some phones working, so I'm not complaining.)

Something about having a book open in koreader on the kindle was preventing it from starting "USB Drive Mode."
(The Kindle is jailbroken and koreader is an application that reads epubs and does a decent job of reflowing PDFs for small screens. I recently upgraded koreader to the bleeding edge and it has been a while since I've added books; it used to not matter whether koreader was open or not.)

Doh! I hadn't tried turn it on and off again.
 
Top