Can't make any ports - "set: Illegal option -o pipefail"

urbanriot

Member

Reaction score: 1
Messages: 57

I recently updated my ports tree and went to update my version of Squid but upon compiling it I receive the following error:

Code:
set: Illegal option -o pipefail
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/www/squid
*** Error code 1

Stop.
make: stopped in /usr/ports/www/squid

Then I tried to compile something else and I get the same error.

Basically I can't compile anything from ports or I get the same error.

Running 11.4-RELEASE-p6 FreeBSD 11.4-RELEASE-p6

I feel like I didn't get some kind of memo... any help would be appreciated!
 

richardtoohey2

Aspiring Daemon

Reaction score: 313
Messages: 633

Working here:
Code:
# portsnap fetch update
...
# freebsd-version 
11.4-RELEASE-p6
# cd /usr/ports/databases/sqlite3/
# make install
...
===>  Installing for sqlite3-3.34.0,1
===>  Checking if sqlite3 is already installed
===>   Registering installation for sqlite3-3.34.0,1
Installing sqlite3-3.34.0,1...
# pkg info | grep sqlite
sqlite3-3.34.0,1               SQL database engine in a C library
 
OP
U

urbanriot

Member

Reaction score: 1
Messages: 57

Code:
root@my-fbsd:/usr/ports/dns # portsnap fetch update
Looking up portsnap.FreeBSD.org mirrors... 4 mirrors found.
Fetching snapshot tag from ipv4.aws.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Updating from Mon Dec 14 10:00:16 EST 2020 to Mon Dec 14 22:15:13 EST 2020.
Fetching 4 metadata patches... done.
Applying metadata patches... done.
Fetching 0 metadata files... done.
Fetching 32 patches.
(32/32) 100.00%  done.
done.
Applying patches...
done.
Fetching 0 new ports or files... done.
Removing old files and directories... done.
Extracting new files:
/usr/ports/audio/ardour6/
/usr/ports/audio/audacity/
/usr/ports/audio/gstreamer-plugins-soundtouch/
/usr/ports/audio/gstreamer1-plugins-soundtouch/
/usr/ports/audio/mixxx/
/usr/ports/audio/mixxx21/
/usr/ports/audio/rezound/
/usr/ports/audio/soundtouch/
/usr/ports/cad/zcad/
/usr/ports/devel/llvm-cheri/
/usr/ports/emulators/rpcs3/
/usr/ports/emulators/yuzu/
/usr/ports/games/vitetris/
/usr/ports/graphics/egl-wayland/
/usr/ports/graphics/mesa-devel/
/usr/ports/lang/zig/
/usr/ports/multimedia/ffdec/
/usr/ports/multimedia/smplayer-skins/
/usr/ports/net-mgmt/netdisco/
/usr/ports/net/librdkafka/
/usr/ports/net/x11vnc/
/usr/ports/security/palisade/
/usr/ports/security/vuxml/
/usr/ports/sysutils/bacula9-docs/
/usr/ports/sysutils/bacula9-server/
/usr/ports/sysutils/pot/
/usr/ports/sysutils/rubygem-bolt/
/usr/ports/sysutils/rubygem-facter/
/usr/ports/www/firefox/
/usr/ports/www/lighttpd/
/usr/ports/www/lychee/
/usr/ports/x11-servers/xwayland-devel/
Building new INDEX files... done.
root@my-fbsd:/usr/ports/dns # cd /usr/ports/databases/sqlite3
root@my-fbsd:/usr/ports/databases/sqlite3 # make
set: Illegal option -o pipefail
===> Options unchanged

set: Illegal option -o pipefail
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/databases/sqlite3
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/sqlite3
root@my-fbsd:/usr/ports/databases/sqlite3 #
 

richardtoohey2

Aspiring Daemon

Reaction score: 313
Messages: 633

Same here:
Code:
# echo $SHELL
/bin/csh
Only asked about shells because there seems to be some discussion over whether it's a "bash thing" or not (or vice versa).

Anything in your /etc/make.conf?
 

richardtoohey2

Aspiring Daemon

Reaction score: 313
Messages: 633

Looks like pipefail was added to sh in 11.3 - https://www.freebsd.org/releases/11.3R/relnotes.html - The sh(1) utility has been updated to add the pipefail option which simplifies checking the exit status of all commands in a pipeline. [r345561]

Any way your userland is out-of-date? This is from my up-to-date 11.4 install:
Code:
% ls -l /bin
...
-r-xr-xr-x  2 root  wheel  429104 Sep 13 10:20 csh
...
-r-xr-xr-x  1 root  wheel  162216 Sep 13 10:20 sh
...
-r-xr-xr-x  2 root  wheel  429104 Sep 13 10:20 tcsh
 
OP
U

urbanriot

Member

Reaction score: 1
Messages: 57

Yepppppp... thanks for spending the time. I'll report back tomorrow!
 
OP
U

urbanriot

Member

Reaction score: 1
Messages: 57

Top