can't login cinnamon

After installing FreeBSD 11.0 Cinnamon I get a login screen, I log in and get 'failed to execute login command'. Can someone pleas help me with this?
 

Attachments

  • IMG_20170412_205223005_HDR.jpg
    IMG_20170412_205223005_HDR.jpg
    1.1 MB · Views: 477
thank you but i can't get past the login. i'm wasting a lot of work time trying to figure this out, so can someone please just tell me how to get past the login so i can run this thing thank you.
 
As lebarondemerde said, you have to check your login command, it's not an authentication problem.
Take a look what you have in /usr/local/etc/slim.conf. The sample file /usr/local/etc/slim.conf.sample has:
Code:
login_cmd           exec /bin/sh - ~/.xinitrc %session
If you use the same, what's in your .xinitrc? Also its permissions may be wrong, and it's simply unreadable.
You may also want trying to log in console by entering console as a username.
 
that doesn't work either. i wish someone could just show me how to get past the login. what's this have to kept secret or something?
 
Personally I do not use slim(1) for many years, so have no hands on experience.
However, if you want somebody to help, you should provide the contents of:
/usr/local/etc/slim.conf
~/.xinitrc
/var/log/slim.log.
 
Rita G.

It is not a secret but something very basic, we all assume FreeBSD users in general already know, even if they are coming from Linux what work basically the same way behind the scenes.
  1. disable slim in rc.conf, to not automatically start it during the boot
  2. reboot (you do not really need to reboot but it is simpler)
  3. login with your user in the terminal
  4. echo 'exec cinnamon-session' > .xinitrc
  5. startx
  6. now you should have your desktop running.
If somehow you do not know how to get back to terminal after have slim running, you just need to change to another tty -> ctrl + alt + F1 (or F2, F3 etc.). However, if you are using the nvidia blob it probably won't work. Then you would need to restart as single user mode, typing 2 in the boot manager, then:

If using UFS:

# mount -u /
# mount -a -t ufs
# swapon -a


If using ZFS:
# zfs set readonly=off zroot
# zfs mount -a


EDIT: now disable slim in rc.conf, reboot and do the first part.

When you have your desktop running, as you see to be in a hurry, we take back on your slim problem.
 
As you are using Cinnamon what supposedly have a session manager you should not need to have a .xinitrc file when using a login manager. Then this line should work, if you did not change anything more in slim.conf:

Code:
login_cmd        exec /bin/sh - %session

Or if for some reason the scripts need bash, you may have to use:

Code:
login_cmd        exec /bin/bash -login %session

However, Slim do not allow to set a default session anymore, and if for some reason there is anything more than Cinnamon, and it (Cinnamon) is not the session appearing at first on Slim, you can change the session pressing F1.

So, a lot of varibles to cover. But we can look on each one...
 
  • disable slim in rc.conf, to not automatically start it during the boot
  • reboot (you do not really need to reboot but it is simpler)
  • login with your user in the terminal
  • echo 'exec cinnamon-session' > .xinitrc
  • startx
after startx i get a black screen with a white x in the middle
 
hm... How did you installed Cinnamon? The X should probably be the mouse pointer.

If Slim was appearing we know Xorg is working, but you have another problem to find.
 
I do not use and never used Cinammon, but if you are interested to make a test, please install something like x11-wm/openbox, what is very simple to see if it is a Cinnamon specific problem.

Then:
  1. echo 'exec openbox-session' > .xinitrc
  2. startx
If it work properly, we will know there is something wrong with Cinnamon and not something else.
 
Ok. Are you loading the driver on boot? I mean, had you added nvidia_load="YES" or nvidia-modeset_load="YES" to /boot/loader.conf?

One may work, the other not.

Had you any advance in there, the x11-wm/openbox worked?
 
There is this PR 217023 what may be affecting you, but if yes it have a workaround.
You should look at Xorg.0.log to find out. Alternatively, you can post it.
 
Rita G. if x11-wm/openbox also didn't run (black screen too?), it seem a problem with the Xorg installation and not Cinnamon.

So, please post the contents of /var/log/Xorg.0.log, /var/run/dmesg.boot, and if you have, the /usr/local/etc/X11/xorg.conf.
 
If you do prefer to have a more pure FreeBSD experience you may want to try GhostBSD instead of TrueOS. TrueOS do several in house customizations what does not allow (can break the system) you to use pkg/ports but their own packages, while the GhostBSD customizations are basically cosmetics.
 
Thank you lebarondemerde for all of your replies. I just replaced True OS with GhostBSD and that computer is very happy with it. I installed it with ‘mate’ desktop environment and it is very compatible with the hardware.

Thanks again.
 
Back
Top