Can't login after update to 10.2-RELEASE-P9 #0

I upgraded from a remote terminal from ver 9.2 to 10.2 following the instructions from Chapter 23 of the manual. Order was as follows.
freebsd-update -r 10.2-RELEASE upgrade
freebsd-update install
shutdown -r now
freebsd-update install
pkg-static upgrade -f

I then tried to open a new session from the remote and got this error message Shared object "" not found, required by ""
Not good! I then tried to login from the computer and the Login Prompt was there so I entered root and hit enter. The following two error messages appeared. I did not get a prompt to enter a password.
in openpam_load_module(): no
pam_start(): system error
Note that at this point I was logged in on the original remote session with su root and could do anything.
I located the following:

I get the same error using any of the valid user IDs. I can do a alt ctrl delete and a reboot occurs and I can boot into a single user mode. When I reboot the system everything that is a remote, Apache, Samba, and Mysql works from a Windows machine. I just can't login to the FreeBSD machine.

The only thing that I have found is references to LDAP and cron. I have looked at how pam works and most of it is difficult to understand what my problem is. This is probably something simple. I don't want to start over with a complete install. I have pulling my hair out for a few days.

Anybody have any ideas how to go about getting the Login to work?


Last edited by a moderator:
Does ldconfig -r show that Does it whine during the boot, /etc/rc.d/ldconfig, about invalid ownership or permissions ?

Last edited by a moderator:
After doing a lot of research I believe I know what the problem is. The upgrade did not do what it was designed to do. The error message Shared object "" not found, required by "" relates to some changes from ver 9.x to 10.x. Version 9 uses the so.6 libs and version 10 uses the so.7 libs. Since I was unable login and get at the FreeBSD sites to download updated files I decided to do freebsd-update rollback. After going through the process I was able to login to the system.

Now I have a different problem, the so.7 libs are required. I did the freebsd-update fetch and the result was this: No updates needed to update system to 9.3-RELEASE-p36. Running freebsd-update install returned this: No updates are available to install. Run '/usr/sbin/freebsd-update fetch' first.

I have decided to throw the DVD in the drive and start fresh. The time I have spent trying bypass problems that was caused by bad update software, I could have had the system restored. Don't get me wrong, FreeBSD after it is installed is a very stable product and will run for years without any problems. Their update path at times is something to be desired as I have had about a 50% success rate since version 6. I have all my data and configuration files stored on a different drive so a new install will not be that much of a problem.

The reason for the update was to determine if a piece of hardware would work with the new version. My old motherboard died and I replaced it with a new one that has only one ps2 port. Something that I overlooked. This machine is connected to a KVM switch and I have to use a dedicated mouse for it. I found an Inland PRO USB to PS2 adapter that would combine the mouse and key board with one USB output. When I plugged it in the system went nuts and spit out constant error messages. I suspect the same thing will happen with ver 10, but it worth a try.
I fixed the problem. I put the DVD in the drive and booted from the DVD and when it asked to install I did so. I had saved off all of the configuration files so I did not have to recreate them. Everything is working fine now.
Oh this is not funny... I want to switch to FreeBSD because it is a full OS and with Linux I had from time to time trouble to get things running again after an upgrader did a lot of things to my system in the dark...
Especially ZFS for Linux integration to Debian was a pain and systemd ran me crazy. I don't want to run a test landscape just to execute a default upgrader procedure with a 50/50 chance.

My hope was that a full basis system from one source would do the magic that Debian loses in a large community and different strategies. Now reading in this forum I get scared to invest time in FreeBSD. 9 to 10 ok but I read here about people having trouble after 10.1 to 10.2. If I want trouble I stay with Debian and those odd debs for ZOL ;)
Last edited by a moderator:
Now reading in this forum I get scared to invest time in FreeBSD. 9 to 10 ok but I read here about people having trouble after 10.1 to 10.2. If I want trouble I stay with Debian and those odd debs for ZOL ;)
When you're at a bakery you'll notice everybody orders bread. If you're at a butcher everybody will be ordering meat. Likewise, if you are on a support forum you'll see nothing but problems. People that don't have issues tend not to post to a support forum.