Can't load ' kernel ' while installing FreeBSD

park0kyung0won

New Member


Messages: 2

Hello,
I'm here to ask you for help
This is my setup

Hardware
------------------------
Dell R510 server 12 bay model
H200 RAID card flashed to IT mode for HBA, attached to R510 PCIe slot
Samsung 850 EVO 250 GB SSD attached to H200

Boot mode set to 'bios' in R510 bios setup menu
Tried USB emulation mode in both 'auto' and 'HDD' in R510 bios setup but same result
SSD marked for boot in H200 bios setup

Installation media
-------------------------
FreeBSD-11.1-RELEASE-amd64-memstick.img
dd'ed to Sandisk USB from linux laptop, image sha512 sum checked

Result
-------------------------
Bios boot manager shows both SSD drive and Sandisk USB drive
When I try to boot from FreeBSD USB stick,
It says,

" Can't work out which disk we are booting from "
" Can't load ' kernel ' "

falls back to some basic shell.
If I type ' lsdev ' it does not list devices.


Anyone successfully installed FreeBSD to R510?
Ubuntu USB stick live boots fine
 

Maxnix

Well-Known Member

Reaction score: 214
Messages: 335

Seems that your USB stick is not recognised. You could try using another one.
 
OP
P

park0kyung0won

New Member


Messages: 2

Seems that your USB stick is not recognised. You could try using another one.

I think it's not USB stick problem but FreeBSD specific for these reasons:
--------------------------------------------------------------------------------------------------------
0. Same result with two other USB sticks

1. With very same USB stick I failed to boot FreeBSD in bios mode, booted successfully with Arch Linux and Ubuntu
 

PacketMan

Aspiring Daemon

Reaction score: 162
Messages: 945

Grasping here.....bios is set to boot from USB first? Does the machine have a DVD drive and you could burn a disc and try that?
 
Top