can't install freebsd 7.0,stuck on hptrr: no controller detected

Hi everyone,
This is my first try on installing on a raid system and a bsd.
I am trying to install freebsd 7 on my setup which has a raidcore bc4852 and adaptec embedded sata host raid bios v2.1-1 2209 but it got stuck during booting of disk 1.

It doesn't even get to the screen that says choose your region.
It says
hptrr: no controller detected.
md0: Preloaded image </boot/mfsroot> 4423680 bytes at 0x0dc6518
ad0: 2866188Mb <maxtor B300R0 BAH411BY0> at ata0-master UDMA100
acd0: DVDR <MEC DVD RW ND-3520A/1.04> at ata1-master UDMA33

The strange thing is when I tried to load from free bsd 6.1 it gets to the sysinstall, and then when I try to partition it complains about my disk geometry.

Right now the system has win xp on it.

Anybody got an idea?

Thank you
Have you tried 7.1? It's still officially "pre-release", but it won't change much more before release. It interacts better with several RAID sets, which may help you.

Make sure that the RAID array is set up before you attempt to install. [I'm assuming, based on your comments, that you want to use RAID.]
This is my first raid system so I am not that familiar with it.

"Make sure that the RAID array is set up before you attempt to install"

How do I set the raid array?

In the controller BIOS - If I remember right, Highpoint controllers require you to press Ctrl H while it's detecting disks to get into it.
I saw on hptrr man page, it says it's a driver for highpoint rocketraid.

I have a raidcore bc4852 is this similar to highpoint rocketraid?

Under adaptec sta hostraid controller (after hitting ctrcl a)
None of these options: manage/create array, add/delete hotspare, initialize drivers can be selected. All of them says no drives selected or no arrays present

Under the controller bios which says BC4852 array configuraion(after hitting ctrl r), I can not create/delete array. The 2 options says not selectable no initialized disks or not enough space available.

When I tried to initialize disks options I can see disk on channel 1-7 but on channel 0 says offline

Ah. That's not a highpoint card, so the hptrr driver doesn't support it. There might be another driver that does, but I've got a christmas dinner to eat before I can get around to looking for that. ;)