Can't install FreeBSD 11.2 (After installation the system won't boot!)

D

Deleted member 55778

Guest


I tried to install FreeBSD on a PC, which had Windows 10 on it. at first i installed FreeBSD using UFS file system and everything was Ok and it installed, then for some reasons i needed the ZFS file system, but after installing, it said:
Code:
No bootable device -- insert boot disk and press any key
i checked and did some digging, but it wasn't cause of the wrong bootcode or any usual reason, everything was Ok as far as i checked.
Then again i tired FreeBSD [UFS] (i though it was cause of the ZFS file system) to see how it works, but it didn't install either! then i realized it has nothing to do with the file systems, cause if it had problem with FreeBSD it wouldn't install it at the first time. I erased and deleted the partitions and tried to install it again but no luck, still the same error. I even tried Linux OS (Ubuntu,CentOs) to see if it really had issues with OS installation, but they installed and functioned fine.
I would really appreciate if anyone can do any help.
 

DavidMarec

Member

Reaction score: 18
Messages: 70

What is the partition scheme you have chosen during the installation process ?
Moreover, make to select the right "boot" mode according to the machine firmware: BIOS or EFI ?
You can also try to install both bootable partitions: BIOS+EFI.
 
Top