Can't find kernel after upgrade from 11.0 to 12.0

TELunus

New Member

Reaction score: 1
Messages: 7

I'm trying to upgrade an old computer of mine from FreeBSD 11.0 to 12.0-RELEASE. I ran freebsd-update -r 12.0-RELEASE upgrade then, after that succeeded, ran freebsd-update install and tried to reboot. It started shutting down, but before restarting it got stuck in a state with text on the screen with the last line showing what the uptime had been. I wanted to make sure it shut down gracefully, so I left it like that for maybe 10 minutes, but since nothing was happening I figured it had probably halted but failed to cycle power, so I hit the reset button on the box. It started booting up, but right after bios it showed:

Code:
BTX loader 1.00 BTX veversion is 1.02
Consoles: internal video/keyboard
BIOS drive A: is disk0
BIOS drive C: is disk1
read 1 from 0 to 0x7e086340, error: 0x40
read 1 from 0 to 0x7e086340, error: 0x40
BIOS 639kB/2095680kB available memory

FreeBSD/x86 bootstrap loader, Revision 1.1
Startup error in /boot/lua/loader.lua
LUA ERROR: cannot open /boot/lua/loader.lua: no such file or directory

can't load 'kernel'

Type '?' for a list of commands, 'help' for more detailed help
OK _
I tried to see if I could ls the /boot/ directory from that screen, but it wasn't really working for me. Doing ls or ls / would show what looked like my root directory, and it listed boot as a directory, but ls boot, ls /boot, ls boot/, and ls /boot/ all gave me an error saying
Code:
open 'boot' failed: no such file or directory
or similar. In fact it seemed like I couldn't ls any directory besides / without such an error.

Any suggestions on how can keep working on this? All help or suggestions are much appreciated!
 
Top