Can't find Asterisk packages in 7 and 8 stable.

bfm

New Member


Messages: 4

Hi Guys!

I was trying to install asterisk from packages in either 7 or 8-Stable and get 'Not found':

Code:
daemon# pkg_add -rn asterisk
Error: Unable to get [url]http://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7-stable/Latest/asterisk.tbz:[/url] Not Found

I build nano BSD appliance based on FreeBSD-Stable and now hit the wall of having to build Asterisk from ports, which is not possible to script inside my build script.

Is it just temporarily absent from packages or is there something wrong with it and that's the reason why there is no packages for Stable?

Any insight is greatly appreciated.
 
OP
B

bfm

New Member


Messages: 4

SirDice said:

I checked the link, but I don't see anything that would tell me that it was indeed built for 8-Stable. Should it not have some build logs attached for every build environment it succeeded to build in?

It's not even on the main FTP site (http://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/Latest/), how come would it make to any mirror then? Do I miss something about the way mirrors get populated with files?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,144
Messages: 39,755

You're right, it looks like it's not even being built. But I see no reason why it's not built though, there's nothing in the Makefile that would prevent it (some ports have a NO_PACKAGE option set).
 

achix

Well-Known Member

Reaction score: 49
Messages: 293

Maybe ports with "dark" build history are excluded from package building process?
I see openoffice.org-3 is also excluded.
 
OP
B

bfm

New Member


Messages: 4

SirDice said:
You're right, it looks like it's not even being built. But I see no reason why it's not built though, there's nothing in the Makefile that would prevent it (some ports have a NO_PACKAGE option set).

I just sent email to flo@ and see what the answer is. Have to rollback to 8.1-release for the time being. :(
 
Top