can't build /usr/ports/graphics/libGL

skyph

New Member


Messages: 5

Hi. Trying to build [font="Courier New"]/usr/ports/graphics/libGL [/font] on my 7.1-RELEASE and stuck on this:

Code:
Stop in /usr/ports/graphics/libGL.

checking for DRIGL... gnome-config: not found
configure: error: Package requirements (x11 xext xxf86vm xdamage xfixes x11-xcb xcb-glx) were not met:

No package 'x11-xcb' found

pkg_info | grep xcb

Code:
libxcb-1.1.90.1   The X protocol C-language Binding (XCB) library
xcb-2.4_1		A tool for managing x11 cut-buffers
xcb-proto-1.3		The X protocol C-language Binding (XCB) protocol
xcb-util-0.3.3		A module with libxcb/libX11 extension/replacement libraries

CVSup'd today, doesn't help.
Please, halp, you my only hope �e
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,099
Messages: 11,412

See if you have the correct versions:

Code:
Information for libGL-7.3_1:

Depends on:
Dependency: xf86vidmodeproto-2.2.2
Dependency: xextproto-7.0.5
Dependency: kbproto-1.0.3
Dependency: fixesproto-4.0
Dependency: dri2proto-1.99.3
Dependency: damageproto-1.1.0_2
Dependency: expat-2.0.1
Dependency: python25-2.5.4
Dependency: xcb-proto-1.3
Dependency: pkg-config-0.23_1
Dependency: xproto-7.0.14
Dependency: libXdmcp-1.0.2_1
Dependency: libXau-1.0.4
Dependency: libpthread-stubs-0.1
Dependency: libxcb-1.1.93
Dependency: libdrm-2.4.4
Dependency: libX11-1.1.99.2,1
Dependency: libXfixes-4.0.3_1
Dependency: libXext-1.0.5,1
Dependency: libXxf86vm-1.0.2
Dependency: libXdamage-1.1.1

Your libxcb is out of date, to start with. Maybe do a portupgrade -a first?
 
Top