Can't boot unless I disable RapidStorageTech in BIOS

Izlude

New Member


Messages: 1

Mobo: Aorus Gaming 7 z370
Dual boot Win10 and FreeBSD on separate drives.
Win10 is in an Optane/iRST config, so it's enabled in the BIOS.
When I want to boot into FreeBSD, I find that the only way to do so is disabling iRST, otherwise this happens during boot:

nvme_ctrlr_start_config_hook
run_interrupt_driven_hooks: still waiting after 120 seconds for nvme_ctrlr_start_config_hook (after 300 seconds, basically forever)

Is there a solution where I can keep iRST enabled? A driver? A flag? Thanks in advance.
 

mjollnir

Daemon

Reaction score: 750
Messages: 1,197

Is there a solution where I can keep iRST enabled? A driver? A flag? Thanks in advance.
Yes, I'm running my FreeBSD laptop with IRST enabled, it works fine. See this howto. To solve your issue, I can only guess because I do not dual-boot:
  • Try disabling the TPM chip in the UEFI/BIOS
  • You boot Windows with CSM or the old native/proprietary BIOS method.
    Try using UEFI boot method instead, it's much faster anyway.
  • There might be some subtle issue when the IRST partition is not on the same drive that you're booting from.
  • Does IRST work successfully under Windows?
Good luck!
 
Top