Solved Can't boot on my usb stick

djazzy

New Member

Reaction score: 1
Messages: 4

Hello,

I wanted to try out FreeBSD so I downloaded FreeBSD-11.0-RELEASE-i386-mini-memstick.img and wrote it on my 16 GB USB key using 'Win32DiskImager' , all went smooth the img wasn't corrupted. I then tried to boot on my usb stick but the following message appeared
Code:
gptboot: primary GPT table checksum mismatch
Then my computer would reboot endlessly.

I tried to use dd instead of the windows utility
Code:
dd if=FreeBSD-11.0-RELEASE-i386-mini-memstick.img of=/dev/sdf bs=1M conv=sync
But got the same result.
I did some research and find this thread. One answer says it's not an issue we can ignore this message.
I don't understand how can I skip this message since it just pops and reboot.

Has someone any clue ?
 

balanga

Son of Beastie

Reaction score: 133
Messages: 3,051

You installed the same as I always do....

Can you try a different USB stick? I have a particular stick which always boots up fine, but whenever I insert it in a system running Windows it immediately crashes the machine.
 
OP
OP
D

djazzy

New Member

Reaction score: 1
Messages: 4

I tried with an other 8GB stick but I still have the same issue :confused:
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

I have seen the same. When I insert a USB stick with the GPT table mismatch error, It crashes Windows. I must write zeros in FreeBSD to burn an image in Windows to it..

Glad to hear I am not the only one.

It does seem you can ignore the GPT error and proceed without problems in installing FreeBSD.

I believe the whole problem is related to UEFI boot.
The original poster should consider tinkering with the bios UEFI settings.
 
OP
OP
D

djazzy

New Member

Reaction score: 1
Messages: 4

I'm using a intel 2 quad Q9550 so i'm on socket 775 I think there is no UEFI.
I will try to add zeros in FreeBSD.
I don't get how to ignore this error, as I said a message pops and my computer reboots.
 

Phishfry

Son of Beastie

Reaction score: 1,396
Messages: 4,113

How about disk controller. Make sure the disk is set to AHCI instead of IDE.

Have you tried the 64-bit installer?
Why not try the full memstick as well instead of mini-memstick.
Maybe even consider FreeBSD 10.3 for older hardware.

I don't understand how can I skip this message since it just pops and reboot.
Maybe you can't because of reboot problem. I have seen it stall on the same error and 'enter' continues booting.

The disk image is smaller than the USB, so the partition table doesn't line up.
This could be it. I always wondered what goes on there.
How backup GPT gets to the true end of disk and not just end of the disk image as you write out the image.
 
OP
OP
D

djazzy

New Member

Reaction score: 1
Messages: 4

I feel so dumb : I was actually using the wrong version
I downloaded the amd64 version and all went smooth. I thought it was only for people using amd cpu...
Thank you all for your help !
 
Top