Cant acess to forum

chris35

Member

Reaction score: 7
Messages: 33

Hi!
Have a "classical" freebsd fresh installation and when i search things from Google that it brings me to this forum i always have message that i cant access on it.
It works only on my Phone or other Linux machine
 
OP
chris35

chris35

Member

Reaction score: 7
Messages: 33

Shoot
 

Attachments

  • 20210822_113736.jpg
    20210822_113736.jpg
    991.4 KB · Views: 59
OP
chris35

chris35

Member

Reaction score: 7
Messages: 33

Notice that i can go to documentation etc, just not alowed to go to forum
 

grahamperrin

Son of Beastie

Reaction score: 807
Messages: 2,608

TCP/IPv6

ping -6 forums.freebsd.org

☑ succeeds.

TCP/IPv4

Code:
% ping -4 forums.freebsd.org
PING forums.freebsd.org (204.109.59.195): 56 data bytes
36 bytes from 104.225.16.157: Time to live exceeded
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 ac95   0 0000  01  01 4331 192.168.1.10  204.109.59.195

36 bytes from 104.225.16.157: Time to live exceeded
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 280e   0 0000  01  01 c7b8 192.168.1.10  204.109.59.195

36 bytes from 104.225.16.157: Time to live exceeded
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 7f7a   0 0000  01  01 704c 192.168.1.10  204.109.59.195

36 bytes from 104.225.16.157: Time to live exceeded
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 8605   0 0000  01  01 69c1 192.168.1.10  204.109.59.195

36 bytes from 104.225.16.157: Time to live exceeded
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 0054 624f   0 0000  01  01 8d77 192.168.1.10  204.109.59.195

^C
--- forums.freebsd.org ping statistics ---
5 packets transmitted, 0 packets received, 100.0% packet loss
%

Code:
% traceroute forums.freebsd.org
traceroute to forums.freebsd.org (204.109.59.195), 64 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  5.247 ms  3.436 ms  3.389 ms
 2  ae50-ner001.thw.as13285.net (78.144.1.1)  8.751 ms  10.497 ms  9.027 ms
 3  ae50-scr101.thw.as13285.net (78.144.1.0)  8.834 ms  8.493 ms  8.899 ms
 4  ae61-scr101.loh.as13285.net (78.144.1.113)  9.182 ms  13.547 ms  9.992 ms
 5  * * *
 6  * * *
 7  126.16.225.104.ptr.anycast.net (104.225.16.126)  120.664 ms  120.664 ms  120.300 ms
 8  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.238 ms  113.464 ms  114.208 ms
 9  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.354 ms  120.489 ms  120.492 ms
10  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.319 ms  113.639 ms  113.556 ms
11  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.213 ms  120.328 ms  120.277 ms
12  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.621 ms  113.311 ms  114.192 ms
13  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.270 ms  120.410 ms  121.002 ms
14  157.16.225.104.ptr.anycast.net (104.225.16.157)  114.598 ms  113.579 ms  114.244 ms
15  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.343 ms  120.808 ms  120.503 ms
16  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.676 ms  113.392 ms  113.177 ms
17  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.230 ms  120.499 ms  121.475 ms
18  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.292 ms  114.068 ms  113.449 ms
19  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.423 ms  120.420 ms  120.303 ms
20  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.302 ms  114.006 ms  113.273 ms
21  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.022 ms  121.628 ms  120.485 ms
22  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.510 ms  113.832 ms  113.850 ms
23  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.755 ms  120.715 ms  120.510 ms
24  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.925 ms  113.661 ms  113.322 ms
25  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.880 ms  120.886 ms  120.559 ms
26  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.706 ms  113.841 ms  113.731 ms
27  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.541 ms  121.528 ms  120.579 ms
28  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.787 ms  113.526 ms  113.922 ms
29  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.470 ms  120.938 ms  120.520 ms
30  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.635 ms  113.284 ms  113.487 ms
31  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.741 ms  120.481 ms  121.837 ms
32  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.842 ms  113.743 ms  113.954 ms
33  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.844 ms  121.412 ms  120.570 ms
34  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.749 ms  113.591 ms  113.322 ms
35  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.983 ms  120.883 ms  120.506 ms
36  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.990 ms  113.816 ms  113.614 ms
37  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.558 ms  120.750 ms  121.184 ms
38  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.921 ms  114.002 ms  115.331 ms
39  156.16.225.104.ptr.anycast.net (104.225.16.156)  125.506 ms  127.593 ms  120.510 ms
40  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.543 ms  113.723 ms  113.934 ms
41  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.061 ms  121.670 ms  120.906 ms
42  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.847 ms  113.684 ms  113.696 ms
43  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.523 ms  120.781 ms  121.558 ms
44  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.881 ms  114.030 ms  113.776 ms
45  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.531 ms  121.348 ms  120.549 ms
46  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.953 ms  113.622 ms  113.994 ms
47  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.855 ms  121.476 ms  120.707 ms
48  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.788 ms  113.751 ms  114.149 ms
49  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.084 ms  120.530 ms  120.524 ms
50  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.674 ms  113.829 ms  113.779 ms
51  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.516 ms  120.774 ms  120.969 ms
52  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.929 ms  114.211 ms  113.517 ms
53  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.123 ms  120.851 ms  120.846 ms
54  157.16.225.104.ptr.anycast.net (104.225.16.157)  114.249 ms  113.666 ms  113.899 ms
55  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.018 ms  120.931 ms  121.195 ms
56  157.16.225.104.ptr.anycast.net (104.225.16.157)  114.163 ms  113.934 ms  114.166 ms
57  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.199 ms  120.760 ms  120.561 ms
58  157.16.225.104.ptr.anycast.net (104.225.16.157)  113.579 ms  113.946 ms  113.686 ms
59  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.507 ms  121.108 ms  121.715 ms
60  157.16.225.104.ptr.anycast.net (104.225.16.157)  114.454 ms  114.740 ms  113.914 ms
61  156.16.225.104.ptr.anycast.net (104.225.16.156)  121.308 ms  120.929 ms  120.716 ms
62  157.16.225.104.ptr.anycast.net (104.225.16.157)  131.600 ms  113.697 ms  128.950 ms
63  156.16.225.104.ptr.anycast.net (104.225.16.156)  120.976 ms  121.132 ms  121.009 ms
64  157.16.225.104.ptr.anycast.net (104.225.16.157)  115.313 ms  113.973 ms  113.731 ms
%

Scope

Multiple users are affected. If the forum is currently available only to people with TCP/IPv6 connectivity: probably a majority of users.

From #freebsd chat:

1629632901470.png
 

grahamperrin

Son of Beastie

Reaction score: 807
Messages: 2,608


Screenshot below:
  • upper window – TCP/IPv6 tunnel temporarily taken down
  • lower window – TCP/IPv6 tunnel brought up
1629633900989.png

– the Page could not be loaded message does use the style that's preferred for the forum.

Compare with this, shared by Feigr in IRC (the same message, different style):

1629634045258.png
 

grahamperrin

Son of Beastie

Reaction score: 807
Messages: 2,608

Why does the FreeBSD system from the thread starter only use IPv4? :eek:

:) enabling TCP/IPv6 at the operating system level might not work around the issue if …

the Internet service provider does not provide TCP/IPv6 connectivity 😱

https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption I'm in a 33% adoption country. At a glance, India has more than 50%.

<https://forums.thinkbroadband.com/general/t/4667422-re-ipv6.html> (2020-12-03) apparently three of the top five ISPs did not offer IPv6, I'm with one of those ISPs, I assume that the situation now is the same.

It works only on my Phone or other Linux machine

chris35 both connected to the same router as the FreeBSD machine?
 

sidetone

Daemon

Reaction score: 921
Messages: 1,883

For me, FreeBSD forums don't work on my computer, if I've recently used my Android phone to access it using Wifi for the same router.
 

grahamperrin

Son of Beastie

Reaction score: 807
Messages: 2,608

traceroute forums.freebsd.org

Better now, although it took a long time to complete:

Code:
% date
Sun 22 Aug 2021 13:24:11 BST
% traceroute forums.freebsd.org
traceroute to forums.freebsd.org (204.109.59.195), 64 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  3.460 ms  3.456 ms  3.493 ms
 2  ae50-ner001.thw.as13285.net (78.144.1.1)  9.445 ms  8.965 ms  8.901 ms
 3  ae50-scr101.thw.as13285.net (78.144.1.0)  8.798 ms  9.164 ms  9.358 ms
 4  ae61-scr101.loh.as13285.net (78.144.1.113)  9.390 ms  9.076 ms  9.877 ms
 5  * * *
 6  * * *
 7  * * *
 8  97.2.225.104.ptr.anycast.net (104.225.2.97)  97.075 ms  95.218 ms  95.248 ms
 9  204.109.59.195 (204.109.59.195)  94.974 ms  95.322 ms  95.120 ms
%

A subsequent run of traceroute6 forums.freebsd.org seemed to get nowhere. The next run, around 13:30:45 BST, completed in less than four seconds.

At least one person who was previously unable to get proper Forum content can now get the content. (I found much the same; temporarily taking down my TCP/IPv6 tunnel did not prevent me from using the Forum.)
 

scottro

Daemon

Reaction score: 909
Messages: 2,061

eternal_noob, it seems that lately, at least with my ISP, FreeBSD doesn't set up ipv6 automatically while Linux does. There was an ipv6 thread around awhile ago. That might be the reason.

My own traceroute, from NYC, was timing out after going from my ISP to level3, though ping is working with both ipv4 and 6.
 

msplsh

Aspiring Daemon

Reaction score: 220
Messages: 622

Had this issue, switched to cellular and it worked. Just assumed it was an IPv6 related issue and waited it out.
 

PMc

Daemon

Reaction score: 685
Messages: 1,381

It was unreachable to me too. I am currently working on implementing ipv6.
So thank you all for the incentive - I occasionally think, why bother, when things do work as they are...
You can repeat doing this, for my testing ;) - I am only an hour or so away from getting the first rough connectivitiy thru to my desktop...
 

scottro

Daemon

Reaction score: 909
Messages: 2,061

I think I put my results in the thread that grahamperrin linked, but for what it's worth I have found, only with wireless connections, not wired, that after everything comes up, I have to run
Code:
 service rtsold restart
before I get ipv6 to the outside.
 

grahamperrin

Son of Beastie

Reaction score: 807
Messages: 2,608

a long time to complete:

This morning, forty-six seconds. Should I be concerned?

Code:
% time traceroute forums.freebsd.org
traceroute to forums.freebsd.org (204.109.59.195), 64 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  3.518 ms  4.122 ms  3.372 ms
 2  ae50-ner001.thw.as13285.net (78.144.1.1)  9.016 ms  9.456 ms  9.765 ms
 3  ae50-scr101.thw.as13285.net (78.144.1.0)  8.808 ms  9.257 ms  8.873 ms
 4  ae61-scr101.loh.as13285.net (78.144.1.113)  9.775 ms  10.026 ms  9.697 ms
 5  * * *
 6  * * *
 7  * * *
 8  97.2.225.104.ptr.anycast.net (104.225.2.97)  95.547 ms  95.449 ms  95.719 ms
 9  204.109.59.195 (204.109.59.195)  95.019 ms  95.201 ms  95.168 ms
0.005u 0.005s 0:46.09 0.0%      0+0k 50+0io 9pf+0w
%
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,290

You're also timing the DNS resolving of the intermediate hosts, not all of them are actually resolvable. And timing the timeouts that occur at step 5, 6 and 7. It's irrelevant how long it takes for traceroute(8) to run. The only thing that matters are the RTT of the hops.
 

Trihexagonal

Son of Beastie

Reaction score: 2,355
Messages: 2,977

Why does the FreeBSD system from the thread starter only use IPv4?
I don't set up IPv6 during the build and block it both ways with pf firewall.

The forums were down all night 8-22-2021. I used one the the free website that check site outages and it reported it as down.

Code:
jitte@bakemono:~ $ traceroute freebsd.org
traceroute to freebsd.org (96.47.72.84), 64 hops max, 40 byte packets
 1  192.168.1.1 (192.168.1.1)  0.499 ms  0.450 ms  0.373 ms
 2  * * *
 3  096-034-057-128.biz.spectrum.com (96.34.57.128)  9.361 ms  9.325 ms  8.933 ms
 4  crr01ovldmo-bue-30.ovld.mo.charter.com (96.34.49.76)  15.079 ms  14.447 ms  14.943 ms
 5  cts01wtrlil-tge-1-0-0.wtrl.il.charter.com (96.34.49.217)  14.975 ms  15.373 ms  14.992 ms
 6  crr01olvemo-bue-200.olve.mo.charter.com (96.34.76.137)  14.941 ms  14.930 ms  14.886 ms
 7  bbr01olvemo-bue-70.olve.mo.charter.com (96.34.2.164)  15.010 ms  16.626 ms  15.030 ms
 8  bbr02chcgil-bue-2.chcg.il.charter.com (96.34.0.12)  22.116 ms  24.199 ms  20.987 ms
 9  prr01chcgil-bue-4.chcg.il.charter.com (96.34.3.11)  19.931 ms  21.167 ms  21.013 ms
10  ae18.zayo.er1.ord7.us.zip.zayo.com (64.125.15.40)  19.993 ms  19.938 ms  19.960 ms
11  * * *
12  ae3.cs2.lga5.us.eth.zayo.com (64.125.29.212)  67.121 ms  50.431 ms  51.032 ms
13  ae13.mpr1.ewr1.zip.zayo.com (64.125.26.149)  50.986 ms  51.692 ms  49.948 ms
14  ae5.mpr1.ewr4.us.zip.zayo.com (64.125.31.235)  50.954 ms  51.692 ms  51.950 ms
15  208.184.34.238.ipyx-076763-900-zyo.zip.zayo.com (208.184.34.238)  51.035 ms  51.551 ms  51.916 ms
16  cs90.cs89new.v.ewr.nyinternet.net (96.47.77.210)  55.024 ms  52.457 ms  50.914 ms
17  96.47.66.42.static.nyinternet.net (96.47.66.42)  51.159 ms  51.571 ms  51.925 ms
18  wfe0.nyi.freebsd.org (96.47.72.84)  54.125 ms  51.159 ms  52.962 ms

jitte@bakemono:~ $ ping -c 3 freebsd.org
PING freebsd.org (96.47.72.84): 56 data bytes
64 bytes from 96.47.72.84: icmp_seq=0 ttl=47 time=51.006 ms
64 bytes from 96.47.72.84: icmp_seq=1 ttl=47 time=50.418 ms
64 bytes from 96.47.72.84: icmp_seq=2 ttl=47 time=49.339 ms

--- freebsd.org ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 49.339/50.255/51.006/0.690 ms
jitte@bakemono:~
 

scottro

Daemon

Reaction score: 909
Messages: 2,061

Yeah, I didn't have any trouble reaching them that night. That was Sunday night. Also, note that you did a traceroute to freebsd.org. That address is from NYI, but the forums are at a different address 204.109.59.195, netactuate.
 
Top