Solved Canon Canoscan LiDE 220 Not Working

Sevendogs

Active Member

Reaction score: 33
Messages: 168

First post - trying to get my Canon canoscan LiDE working. devfs rules are in place, normal user results from sane-find-scanner -q and scanimage -L:
Code:
found USB scanner (vendor=0x04a9 [Canon], product=0x190f [CanoScan], chip=GL848+) at libusb:007:002
device `genesys:libusb:007:002' is a Canon LiDE 220 flatbed scanner
When I run xsane or xscanimage, I get an error saying:
Code:
Failed to open device 'genesys:libusb007:002': Invalid Argument
My scanner is listed in /usr/local/etc/sane.d/genesys.conf:
Code:
# Canon LiDE 220
usb 0x04a9 0x190f
I have done quite a bit of searching and cannot get the scanner to work under FreeBSD. I specifically bought this scanner because according to sane, it is supported 100%. It worked perfectly under Linux using sane and xsane.

Thoughts anyone? Thanks in advance!
 

shepper

Aspiring Daemon

Reaction score: 322
Messages: 874

I run a Canon Flat Bed scanner in OpenBSD without issues

I'm going to make the assumption that you are trying to scan as a user and raise the possibility that your permissions/group are not correctly set.
A quick way to test would be to run xsane from a root WindowManager/DE. If it runs then you have a permissions problem.
 

asteriskRoss

Well-Known Member

Reaction score: 160
Messages: 447

Sevendogs, I also just bought this model of scanner precisely because it would be fully supported by graphics/sane-backends. I haven't had a chance to try it yet, mainly because I was waiting to upgrade my desktop system to FreeBSD 10.3. I'll let you know if/when I get it working.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

shepper - I should have posted that I already eliminated permissions issues but I didn't include that in my post, sorry. Initially the behavior was different, telling me my devfs rules were wrong but I corrected those and now I can run the command as a normal user. I get the error as both root and my normal user. I need to figure out why sane is spitting the error referencing
Code:
genesys:libusb:007:002
when I have
Code:
usb 0x04a9 0x190f
in my configuration. It may mean nothing and just be the way sane references the USB device. What is frustrating is that this SHOULD work o_O
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

@asteriskRoss - precisely why I bought this model as well! Thanks for the post and let me know if you get it working; I will do the same.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

Upgraded to 10.3 with the same results. Very frustrating, will do more digging. The sane-backends version shows this scanner as fully supported.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

OK, progress but not success! I added the following to my /etc/devfs.rules:

Code:
[system=5]
add path ugen7.2 mode 0664 group usb
add path usb/7.2.0 mode 0666 group usb

deleted my .sane config folder and started xsane. Xsane now starts, but when I try to acquire a preview, the scanner starts to move then I get an error saying "invalid argument". Running

scanimage -T gives the output "scanimage: sane_start: Invalid argument".

Sigh.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

Success! Went off and had a little reunion with Arch Linux then came back with a completely fresh install. Added the usb group, added my user to the usb group, then added the following to /etc/devfs.rules:

Code:
add path 'ugen[0-9]\*'  mode 666 group usb
add path 'usb/\*'           mode 666 group usb

Restarted devfs with /etc/rc.d/devfs restart, did a sane-find-scanner -q as my user, got the correct output, then did a scanimage -L as my user and got the correct output. Crossed my fingers and fired up Xsane - w00t! No errors. Put a document in the scanner and lo-and-behold, it previewed and scanned. Very slowly I might add - took a while for Xsane to actually do anything but it eventually previewed and scanned. Whole process of scanning took about 2 minutes. Much faster on Linux, not sure why. Important thing: it works!
 

tingo

Son of Beastie

Reaction score: 628
Messages: 2,526

When you edit the first post, there is a dropdown menu or something like that.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

Got it, thanks! I used the Thread tools option at the top of the thread and then edited the title.
 

asteriskRoss

Well-Known Member

Reaction score: 160
Messages: 447

Hi Sevendogs. I'm glad you got this working. I finally got around to setting up my Canon LiDE 220 scanner on my FreeBSD 11.0 desktop, reading the Image Scanners section in the FreeBSD handbook. After some initial testing it appears to work just fine without any specific configuration on my part, though I already had permissions set so my standard user account can access USB devices. I must admit this was a bit of a surprise given how painful I find setting up printers.

You made a comment about speed. I found actual scanning is certainly no slower than it was when using the scanner with a Mac, though is unsurprisingly much faster at a low resolution.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

asteriskRoss - I think I didn't clarify: when I say "slower" I meant slow to start, not the actual scan job when the light/camera is moving. It's strange: on Linux the scan job started immediately when I pressed "scan" on whatever app I was using. On FreeBSD its takes 5 or 10 seconds before the job starts. Not a big deal just odd.

Glad you got yours working!
 

asteriskRoss

Well-Known Member

Reaction score: 160
Messages: 447

I also find there is a short delay of the order you describe whilst the scanner actuators seem to activate and move the arm slightly forwards before resetting for the start of the scan. Perhaps it is a method of ensuring the scanning arm is in the correct starting position? Using OS X and the official Canon drivers on a different machine I saw similar behaviour so I assumed it was normal for the scanner.
 
OP
Sevendogs

Sevendogs

Active Member

Reaction score: 33
Messages: 168

Interesting - I never used the scanner on either OSX or Windows so can't say how it worked. At least it works now, I am happy about that.
 

tomysurya

New Member


Messages: 3

can someone help me with canon lide 110, installed sane-backends, following the instruction post instalation, following handbook, the scanner was detected, i can hear the startup sound (using skanlite) but then its failed, it gives me error: invalid argument
 
Top